Customizer preview not available + Can't turn off "Leave a comment" on homepage

Hi! :slightly_smiling_face:

I’m having a few problems… I can’t seem to turn off the comments for my homepage. I have searched for the option in the page edit options and in the theme customizer but I can’t seem to find it. I don’t know how or why there suddenly appeared an option to leave a comment on my homepage. It was actually never there.

Also I am having preview problems in the theme customizer. I am getting the Uh Oh! Warning.
The preview HTML did not include a closing ,/html.; tag. It may fail to load or work properly.

Hope you guys can help me out here. :kissing:

Hi there,

You will be able to disable the comments by going to Settings > Discussion menu and set the appropriate options there.

For the customizer problem please kindly follow the steps mentioned in the article below:

If you still have the problem kindly get back to us with the URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Hi thank you for your answer.

Unfortunately there is noting in Settings > Discussion that can turn off Comments on the home page. No pages I can turn on or off or locations I can select for the comments to appear. Any other suggestions? :disappointed_relieved:

I found the plugin that was causing the bug. It was W3 Total Cache… can someone advice a different plugin that does the same thing and does go with X?

Hello There,

1.) Your homepage is using a default page template. Please edit the homepage and make sure that comments is also turn off.

2.) The issue is happening because you have enabled the minify option for JS and CSS. You can still use that plugin. Just do not minify the JS/CSS to avoid the issue. And if you are still creating or building the pages, I would recommend that you deactivate the plugin temporarily. Caching plugins are best to turn on only when you’ve finished building the site.

Hope this helps.

1 Like

Thank youuuuuuuuu! :heart_eyes: Solved all my problems. :smile:

I will follow your advice for W3. Really thanks a lot!

We are delighted to assist you with this.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.