Custom "The Grid" skin not working on multisite

I’ve added a custom skin to the grid using this function.

add_filter(‘tg_register_item_skin’, function($skins) {

// just push your skin slugs (file name) inside the registered skin array
$skins = array_merge($skins,
    array(
        'tg-pomo-blog-skin' => array(
            'filter'   => 'POMO Blog Skin', // filter name used in slider skin preview
            'name'     => 'POMO Blog Skin', // Skin name used in skin preview label
            'col'      => 1, // col number in preview skin mode
            'row'      => 1  // row number in preview skin mode
        )
    )
);

// return all skins + the new one we added (property)
return $skins;

});

I’ve done this on about a dozen sites without problem. This is the first time i’ve tried with multisite. When I go to choose a skin in the editor it just says “Please wait, loading skins…”. Is that functionality not supported in multisites.

Hi there,

Thanks for writing in.

Might not be supported but it could be due to Multi site itself (permission). I have seen many issues that only pops in a multi site setup. Would you mind providing your site’s URL and admin login credentials? I’ll just gather some information then I’ll add this to our issue tracker.

Thanks!

Hi there,

Thanks, it’s due to internal server error and it can’t load the list. Would you mind providing your FTP login credentials as well? I can only find the error’s information through that.

Thanks!

Hi there,

Thank you for the information. I checked the error log and this was the error:

[22-Apr-2018 01:44:25 UTC] PHP Fatal error:  Cannot use object of type WP_Post as array in /wp-content/plugins/pomo-multisite-blog/pomo-multisite-blog.php on line 84
[22-Apr-2018 01:45:30 UTC] PHP Fatal error:  Call to undefined function The_Grid_Element() in wp-content/themes/pro-child/the-grid/masonry/tg-pomo-blog-skin/tg-pomo-blog-skin.php on line 21

The first error shows that there is a PHP error in pomo-multisite-blog plugin which you need to follow up with the plugin developer. At the moment please disable that plugin.

The second error shows that the customization you have done on the Pro Child Theme regarding The Grid causes a PHP error. Check the case by changing the theme to the parent normal Pro theme. If it works then you need to check your changes in tg-pomo-blog-skin.php and see what did you do which caused the problem.

Thank you.

Those errors have been resolved for some time. The skins still aren’t loading.

Hi there,

It’s not fixed, please check the error logs and its date, it’s still there :slight_smile:

I disabled the plugin temporarily through (not totally disabled through admin but through FTP, that shouldn’t affect any data). Then I also disable the the-grid folder in the child theme. And the internal server error is gone.

Hence, the error is due to the 3rd party plugin and the custom template. Unfortunately, we can’t cover this kind of issue. I recommend contacting the plugin author, and a developer for the custom templates.

I also tried fixing it without success since the cause of internal errors are from multiple location.

Thanks!

That simply is not consistent with what I’m seeing.

I eventually discovered that your plugin was instantiating one of my variables, $pomo_post_id, with the value of a string “fake”.

I worked around the issue to fix both our plugins.

Hey There,

We are just glad that you have figured it out a work around to correct the said issue.
Thanks for letting us know!

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.