Custom Fonts not working :-(

Hi, I am trying to add the following fonts:

Avenir and Joane to a new site, I have used the format .woff as per here: https://theme.co/docs/font-manager

Following to the letter… Font manager is enabled as well as all the options under Miscillanious in the settings.

I have dev mode set on the server so no caching…

I can select the font I want etc it just doesn’t work… please help! Thanks

Hello @wolfproductions,

Thanks for writing to us.

I checked your site it seems that the URLs are not fully replaced while moving the site from HTTP to HTTPS site and that causes the Mixed Content issue [ HTTP and HTTPS ] blocking to load of the Font files.

I would suggest you replace the URL properly and check this again, there are many URL replacement Plugins available in WordPress which help you to replace the URL.

This article will be helpful in this:https://www.wpbeginner.com/plugins/how-to-update-urls-when-moving-your-wordpress-site/

Also, remember that the exact URL should be mentioned in Setting > General, WordPress Address and Site URL, including the protocol i.e HTTP/HTTPS.

Hope this helps.
Thanks

Thank you Prakash, that’s helpful

Hey @wolfproductions,

You’re welcome! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.