Custom font not working - Font Manager not previewing, .ttf file unacceptable


I’ve seen a few threads address similar issues but nothing suggested in those threads has worked for me.
I just migrated my dev site to new hosting - the custom fonts worked fine at first but now that the live domain name has switched over suddenly the custom fonts are no longer working.

I downloaded Velvet Blue Replace URL - It replaced many URL’s but that didn’t fix the issue.

I tried to re-upload the font files and I was given an error message that .TTF wasn’t an acceptable file format for security reasons.

The font I am trying to adjust is Antonio and its used for pretty much all the headers on my site that just went live so I need help!

Hi @Lacylou,

Thanks for reaching out!

I just check your website and you have a Mixed Content issue on your font. The font was loaded as http while your current website is now using https. I suggest that you disable your CDN for the meantime and let see if it fix your issue.

On the other hand, you need to add this code in your wp-config.php so that you can upload the .ttf files in your WordPress media.


Hope that helps.

Thank you.

Thank you! I was able to fix the font upload issue with your help – but I am still having issues with the fonts. I’m using SG optimizer to enable the SSL cert on the site - I turned it off but it doesn’t seem to have done anything… is this something i need to wait on or should i try something else? Thank you

Hi @Lacylou,

In my previous response, I suggest that you disable your CDN because currently, it is the one that hosts your files or you can contact your hosting provider about the CDN. Once the CDN is disabled, please let us know how it goes.

Thank you.

Would you be able to better explain what you mean by CDN - I spoke with my host support and they said I don’t have CDN enabled…

Hi @Lacylou,

A content delivery network ( CDN ) refers to a geographically distributed group of servers that work together to provide fast delivery of Internet content. I check again your website and the CDN is now disabled. Would you mind sharing your admin credential so that we can check your back-end? To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi @Lacylou,

I don’t see the issue anymore about the font in the google console. I just enabled the Better Search Replace plugin in your website then search for and replace it with Would you confirm that the font issue is already fix?

Thank you.

It looks to be working now - thank you so much!

Hi @Lacylou,

Glad that it is working now.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.