Custom font not loading

Hello there,

I have loaded a TTF font family into Custom Fonts and they seem to have uploaded ok and are showing in the font manager under Custom Fonts ok, but they are not showing in the text editor.

Any idea what I am doing wrong? I have loaded other TTFs without an error.

Kind Regards,


Hey Spencer,

Unlike the other fonts, you have not added the Be Cool font in the Font List. It should be added in the Font List before it becomes available for selection in the builder.

Hope that helps.

Hi @christian,

Thanks for getting back to me. I have added the new font to the font list and it is available in the text element editor but the font is not rendering / visible - the browser is displaying a generic serif.

Please see the attached images - the last one show the font file on my local machine and you can see that it is a legit file / uncorrupted.

Any idea why it isn’t appearing?

Kind Regards,


Hello Spencer

It seems that the URLs are not fully replaced while moving the site from HTTP to HTTPS and that causes the Mixed Content issue [ HTTP and HTTPS ] blocking to load of the Font files.
If you check on the font file on the media font URL is with HTTP but where you view your site its site URL is with HTTPS.


I would suggest you replace the URL properly and check this again, there are many URL replacement Plugins available in WordPress which help you to replace the URL.
This article will be helpful in this:

Also, remember that the exact URL should be mentioned in Setting > General, WordPress Address and Site URL, including the protocol i.e HTTP/HTTPS.

Hope this helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.