Custom Font — No Change

Hello!

I have added a custom .woff font. I converted the file from .otf to .woff using an online convertor since .otf files don’t work. However, when I added the font, added to the ‘Heading’ and then use that style it is not displaying.

Am I missing something here? I will add a secure note.

I should mention the heading font is primary being used as the subheadline throughout the site. It can be seen on the homepage throughout.

Hello @tkcostello,

Thanks for writing to us.

It seems that the URLs are not fully replaced while moving the site from HTTP to HTTPS and that causes the Mixed Content issue [ HTTP and HTTPS ] blocking to load of the Font files. Please have a look at the given screenshot in the secure note. I would suggest you replace the URL properly and check this again, there are many URL replacement Plugins available in WordPress which help you to replace the URL.
This article will be helpful in this:https://www.wpbeginner.com/plugins/how-to-update-urls-when-moving-your-wordpress-site/

Also, remember that the exact URL should be mentioned in Setting > General, WordPress Address and Site URL, including the protocol i.e HTTP/HTTPS.

Hope this helps.
Thanks

Mixed content was the issue. Thank you — should also fix some other issues!

Hi @tkcostello,

Glad that we are able to help you.

Thanks