Custom font doesn't render

Hi, I’ve tried everything I can think of here. The font Nitida Display isn’t rendering (it’s showing as Times instead).

I’m sure this was working. Another custom font on the site (also using .woff and .woff2) files broke recently (on a theme update) but we’ve resolved that just about, by removing all the old versions and re uploading to the media lib.

We’ve tried the same thing with Nitida Display. Also tried adding a new custom font option in Fonts. Thought it could be insecure content, i.e. perhaps the font file loading http rather than https, but that doens’t seem to be the issue.

Any other suggestions, or are you able to take a look please?


Hello @aminternetdesign,

Thanks for writing to us.

It might be the Mixed Content issue [ HTTP and HTTPS ] blocking to load of the Font files. Please remember that the exact URL should be mentioned in Setting > General, WordPress Address and Site URL, including the protocol i.e HTTP/HTTPS.

In case if it is correct, I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing for Plugin Conflict
  2. CSS/JS Customization
  3. Version Compatibility
  4. Disabling Cache

I would also suggest you clear your browser cache and then check it again. If it doesn’t work for you, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


Hi Prakash thanks for the reply and suggestions.

I’ve just run through everything you advised. Still can’t find an issue.

I’ll add a secure note with the details now.

Hi @aminternetdesign,

You need to add the custom fonts into the font list after importing the files. I went ahead and added that and it starts coming into the Font list.

Hope it helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.