Custom Font does not show

I tried to use a custom font on my website.

  • I converted it to the recommended .woff format
  • Added woff to MIMES so I can upload it to WordPress
  • Selected the font in the custom font section
  • Tried it with both Font Manager on and off

The font still does not show when selecting it. What am I doing wrong here?

Hello @nielsvandenbergh,

Thanks for writing to us.

To add a custom font please have a look at our doc In case if it doesn’t work for you, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


Hi there! Thank you for your swift reply. I have shared the login details in a secure note.

I’ve tried getting answers from the doc, but without success.

Hope you can help!

Thank you,

Hi Niels,

I have created a Test Page and set the Mint Blue font to the Headline element and it loads properly in the Frontend.


Hi there!

Problem is that that’s Times New Roman, and not the font I am looking to show:

So it does load the family, but not the underlying font?


So the problem is not resolved. See my screenshot for what the font should look like. Thank you for you help!

Hello Niels,

You are having a CORS or Cross-Origin Resource Sharing issue on your site. This means that the font files were uploaded with HTTP and then you have added your SSL, changing the URL to use HTTPS. To get this resolve, please install the Search and Replace plugin. You will need to search for a keyword that is not using HTTPS and replace it.

Hope this works out for you and check your font files on your site again.

You absolutely rock. That was it! Thank you so much!! Made my day.


You are most welcome @nielsvandenbergh

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.