Cornerstone WPML page translation problems

We are using WPML translator ( manual translations)
we want to translate homepage from original LV to EN by copying templates and then changing picture and texts,
but style is messed up when we put the same template in EN language, you can see in
we can’t find where is the problem, because original page is fine .
We made manual translations in WPML also copied
But the style is messed up anyway.
Could you help, Best Regards.

Hello There,

Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. If you’re using a CDN(ex: CloudFlare), please clear the CDN’s cache and disable optimization services. For the CloudFlare you also need to follow the steps below besides the developer mode:
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Switch to the parent theme to check if the issue persists.
  7. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  8. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Hi @Saulis,

How did you translate it? have you translated it through Wordpress editor or within the builder? It looks like you only translated it through the editor.

If the page is created from cornerstone, then the translation should be made from cornerstone too.

About the duplication, you don’t need to do that as it should be automatic when you click the flag icon the builder for translation. Once you click the flag icon and there is no translation, it will ask you if you like to start from Blank (page with no content and you need to manually fill in the content) or from Existing page (like if the main page is English, it will duplicate that English page exactly where you can then change texts and wordings as translation).

Please check this thread, it’s discussed there too


Hi, thanks, when I translate with cornerstone, it works, but I can transalte images.
even if I make blank pages, it will copy from main page, in my case latvian, but have images with words,
when I translate imges with media translater, they don’t work in cornerstone, it takes only main language.

Hi @Saulis,

What do you mean by media translation? Would you mind providing a video recording of how you’re adding the image? You should manually insert different images for each page and you don’t need to translate it. The translation should be already added if it’s an image using any photo editor.


Hi there,

Anything I could help with the translation? I just noticed the thread is bumped, maybe we’ll need more clarification about the issue.


Yes, I made a page, then edit cornerstone, pushed button, flag in the right corner.
primary language is Latvian.
So I made something in Latvian, then switch to EN, second language, edit something and after that do changes again in Latvian and it automatically copies Latvian content, why is that?

Now it is that, I made page in primary language, saved template (layout)and copied in secondary language and it is not working correectly?
There something goes wrong, when I make page? I cant input custom HTML texts like h3 or what?
Thank you, best regards

Hi @Saulis,

Is it still related to images? I recommend disabling the WPML Media plugin and try the images on the translated pages again.

And would you mind providing a video recording for all of these issues? I couldn’t try it directly since you said it automatically copies them (overwriting) and I’m afraid I may contribute to issues if I do that.

But I do deactivate the Advanced Custom Fields Multilingual plugin as it caused errors for text element that makes editing not possible.

I also created an X TEST page to see if the overwriting and automatic copies are occurring and it didn’t happen on first 3 saves and loads, but then it happens and I can’t change the content anymore. So perhaps this isn’t related to translation but could be saving issue since it’s too slow on my end. And on my end, it’s the Latvian is the one broken as it won’t save the changes, it remains in English after 4th save and page reloads.

Your site is slow and the builder changes won’t take effect instantly. I had to wait just for the added short-text to regenerate a preview. I recommend increasing your site’s memory limit as for step 8 as @thai’s recommended.

With this many issues, I recommend cloning your site in staging. It’s better to test it there before adding more issues. You could do that by using All in one migration plugin, we’re not migrating, but we just need to export the site using that plugin and import it to a new Wordpress installation (in sub-folder or sub-domain). Then please provide the FTP login credentials for that staging.


Page was slow, because I was working on site at that moment.

Advanced Custom Fields Multilingual - That was the problem.
when i deactivate it, cornerstone works on second language, with this cornerstone make like html code,
when i edit second language page, in my case EN. So it wont allow make corner stone content in second language.
It seems problem is solved, thank you very much!

Glad to hear that the problem is solved now. :slight_smile:

Hello @Saulis,

Thanks for updating the thread.

Can you please share the WordPress admin details for the staging site in secure note for us to take a closer look?


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.