Cornerstone: The preview was unresponsive after loading. This is most often related to a plugin conflict or aggressive page cacheing

Hi there,
We are still having trouble editing with Cornerstone/X-Theme:
"The preview was unresponsive after loading. This is most often related to a plugin conflict or aggressive page cacheing.

Origin URL:

Preview URL:"

I have tried clearing caches and deactivating caching plugins and end up with the same error.
When we do not get the error, I get a “preview” where all of the content in between header and footer has disappeared - see image:

It has been months since I have been able to edit my website due to Cornerstone suddenly not working after working flawlessly for years up until a few months ago. I got X-Theme so I wouldn’t have to be a developer to build a website. Now it seems I need one just to fix this mess that I frankly don’t have the expertise to figure out. I tried changing catching plugins, as well as some recommendations I saw on my previous thread and others’ thread, with no different results. Please help. Thank you.

Hi there,

Thank you for your message. We understand that you are struggling to find out the reason why this is happening in your case. We also need to go step by step and rule out the possible cases to be able to find out why this is happening.

Kindly follow the steps mentioned in this article:

Get back to us with the result of each step and kindly get back to us with the URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you for your patience.

Hi there, thank you for the response! I recently went through the suggestions on the troubleshooting page:

I am not using a child theme.
Clearing the cache did not help.
A couple of days ago I did a plugin test and found that when reactivating the “AMP” plugin, I got the same error. However, when I clicked try again I was able to pull up the preview.
Next I activated Revolution Slider which is when I could not get it working at all.

The only workaround I have found is to clear the cache and temporarily deactivate Revolution Slider in order to edit with Cornerstone, but this doesn’t even always work. It usually comes up with the error and I have to refresh it and hope it loads. Last time I tried it, most of the visual content just stayed in a spinning wheel. Sometimes I am getting a 504 error as well. Anyway, I have version of Revolution which is supposed to be compatible so I may not even be successfully pinpointing what the problem is.

This is still frustrating and I’m pretty confused about it all but at least I kind of(?) have a workaround. Any further insight would be appreciated. I have added my credentials in a secure note. Thank you!

Hi there,

Thank you for the detailed information. The fact that if the Revolution Slider is activated the Cornerstone is not responsive gave me an idea. It seems that you have not enough PHP memory limit on your hosting service and the server runs out of space when it wants to work both with Cornerstone and the Revolution Slider.

The other point I see is that I constantly see 504 error and sometimes the 503 error when trying to access your website. This is 100% a problem of a hosting service provider and most probably is due to lack of enough resources. You either need to consider changing your hosting service provider or using a none shared plan of your hosting.

You can check our hosting places if you are interested:

I installed the WP Server Info plugin and if you go to Dashboard > Wp Server Info you will see that the PHP memory limit is 256. Please increase that to 512, you may need to contact your hosting service provider to do so.

Kindly get back to us with the result of the test above, Another point that I suggest that you can test is to move your website to your local machine or a temporary other test server and check the result, that way you will see if the issue is from the hosting plan or not.

Thank you.

Thank you for the reply again. I had my host increase my PHP limit. However, when I look on the Dashboard, it still says 256. I had two separate reps confirm that it was increased. I am not sure why that is. Do you see anything different on your end?

I am still getting either the cacheing error or a blank page as shown in my image in the OP.

I will definitely consider switching to hosting if I don’t make some real progress with this soon. This couldn’t be more frustrating and on top of it all my site is often slower than it should be. So I am heavily considering it. I imagine it could help things run much more smoothly.

Do you have any guidance on moving my website to a local host to test that? That’s something I’d like to try first, but I’m not entirely sure how to do that. Thank you.

Hi there,

I think you also need to make sure you added the 512MB option to the wp-config.php file of your WordPress installation root folder as only having it from the hosting site is not enough. SO I suggest that you check this article for more information:

Good idea to test the case on your local machine or a test server. You can do that following the steps below:

Also, you can check the official documentation of WordPress regarding that:

If you use our hosting service you will have no issues using the ecosystem, and if there are any problems you will have support staff which is already familiar with the X and Cornerstone and the whole Themeco ecosystem so they will be a better help on each case.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.