Cornerstone not working properly on my sites


I recently went to use Cornerstone to build some pages on my sites ( and, and I’m experiencing multiple issues. I’ve looked at other threads for help, have cleared caches, have tried both Chrome and Safari, have tried updating the Theme and Cornerstone, but still have not been able to resolve the issues.

For some reason, the Theme wasn’t auto-updating, but when I looked to see if it was up to date, it said it was (even though it actually wasn’t). So then when I discovered this and went to update it to 6.0.4, it messed up a bunch of the stylization on my sites. I don’t have time right now to fix all of it, so I went back to the stability release (4.6.4) of the Theme in order for my sites to look and run properly until I have time to deal with all the changes needed to update to 6.0.4.

I think because I’m not on the newest Theme, Cornerstone (v. 3.0.4) refuses to work properly. None of the new elements will show up in the editor, only the Classic ones. But even if I use the Classic elements, NOTHING will show up on the live page. It doesn’t matter what changes I make or which elements I use, nothing shows up on the actual page. I need Cornerstone to work so I can build the pages I need because I’m not a coder nor a web-designer, just a humble employee trying to build a couple sites for my company.

Any help you can give would be great. Do I need to go back to an older version of Cornerstone? If so, how do I do that? Again, I’m not an IT person, so I don’t know all the jargon, but I need my sites to work.

Thank you in advance.

Hi There,

Thanks for writing in! If you haven’t done so far, I would highly recommend you to configure a plugin to monitor your PHP errors. You can use error log monitor plugin to do so ( and your server error log can be accessible through your WordPress back-end.

With regard to your original issue, first try re-generating your permalink settings and see if that is related to your .htaccess file.

  • Check your permalink settings (General -> Permalinks) and set Postname save changes to re-create your .htaccess file.

Then the next possible issue would be that you’re running out of your memory. You can try increasing your PHP Memory limit. You can do this by editing your wp-config.php file which can be located under the root of your WordPress installation.

Add the following lines into that file.

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

Check the following as well.

  • Make sure that you’re running at least PHP v5.6.x or later to avoid any WordPress related incompatibility issues. If you’re not sure what your server configurations and settings are, install a plugin like WP-Serverinfo ( and check your server info by head over to Dashboard -> WP Serverinfo area.
  • Check your PHP Max Execution Time and set it for 300 for optimal usage.

Further, our troubleshooting guide here (

Let us know how it goes.

Thanks for your reply!

I tried upping the memory as high as current settings allow (256M, not 512M as suggested).

As far as I know, we’re not running any caching plugins or CloudFlare.

I checked, and we’re running PHP v5.6.

The PHP Max Execution Time was set to 30 but was dynamic. I changed it to 300, which is the max for our server.

I looked at the troubleshooting guide, but the problem is that I’m not getting any errors on the screen. It always says it saves my work, but then the preview of the page is just blank. There’s nothing on it except the header and footer.

Unfortunately, it’s still not working properly (see screen shots below).

sections and rows don’t even display (on

On, the Classic Elements will show up in the editor…

…but don’t show up on the site:

Thank you

We’ve had to revert back to Theme v4.3.4 because even 4.6.4 was messing things up. It’s frustrating that every time we update the Theme, the styling gets messed up (i.e. a lot of CSS getting broken or ignored. Images being sized incorrectly. Layout being off. Broken menu layouts.). We need to be able to update without going through this every time. Is there not a way to make it work more seamlessly?

Also, it seems like Cornerstone just doesn’t want to work on our sites at all. Please help!

Hi @axis,

I see that you have revert your version to the previous version. To help you further, we would like you to replicate your setup to a dev site then from there, we’ll try to help you the best we could do. Share us your dev admin credentials and FTP.

Don’t forget to share your private details in a secure note and please replicate the site with the same host so that we could replicate the fix to your live site.

Thank you so much.

We have a multisite network set up. So on the dev site only the main site will work. I don’t have all the subdomains set up. The dev site is I will add a secure note with login details.

Hello There,

The ftp access is working and we were able to logged in. Regretfully it is displaying an empty folder. It could be that this details points us to the wrong folder and not to your Dev Wordpress installation. Please double check the access.

Please also update X theme in your dev site because Cornerstone 3.0.4 works best with X theme 6.0.4. You may need to update the X theme manually since you are in a multi site set up. To know more how to update, please check this out:

Please let us know how it goes.

I had the same issue with a site hosted on GoDaddy (that isn’t relevant to the fix). Manually updating X from 4.6.4 to 6.0.4 worked in my case.

Hi There,

Thanks for clarifying!


Hey sorry about that. I fixed the FTP. It now points to the correct directory. As far as updating goes, that’s up to you guys as what you want to try and fix.

Right now if we update at all past 4.3.2 our site styling gets really messed up. That happens even with running a child theme and all that. It’d be great if Cornerstone still worked with our site as it is. If we need an older version of Cornerstone that’s fine, we can revert.

Or if we update to 6.0.4 and Cornerstone works great with that then we need a solution for why the theme is breaking all of our current styling. I don’t have time to spend a week essentially redesigning our current website. But I do need our other employees to be able make and update pages that were built in Cornerstone. Right now they can’t do that.


Hello there,

I’m sorry to say that you’re FTP on the secure note isn’t still working. Kindly double check it.

Upon upgrading to the latest versions, X 6.0.4 and Cornerstone 3.0.4, I suggest you first setup a staging server and do the the troubleshooting cases there. We can do the tests together. In this manner, your live website won’t be affected.

Let us know what you think. Thank you.

Ahh, I see what happened. The username got switched to a different domain.

Hello @axis,

Thanks for updating the details and FTP works fine now. :slight_smile:

Another support staff here. Can you please try updating the theme to it’s latest version on a staging server? Actually we are not allowed to fiddle/update with the core functioning of customer website? You can take a look at following tutorial to setup staging environment.

Once you have staging setup done. Please take a look at following guide to update X Theme. Because you are using old version of X Child theme, I suggest you to activate the Parent theme first:

Upon updating the theme, I also suggest you to download and install the new version of X Child theme and move all the codes from old child theme to new one. Please use following source to download child theme.

While moving the codes, please ignore following code.

@import url( '../x/framework/css/site/stacks/renew.css' );

Once you have updated X Theme, installed, activated and moved all the codes from old child theme to new child theme. Kindly revert back to us and then we can take a look at the styling issues that’s coming up.


Hello @Prasant, @axis,

I am facing exactly the same problem.

My hosting is Windows Hosting with Plesk. I am using latest versions WordPress, X, Cornerstone, Slider Revolution. I have been trying long to figure how what could be the issue. I also tried a few settings as mentioned by mldarshana.

In my scenario there seems to be some conflict with Slider Revolution Plugin. When I disable it my Cornerstone Editor works well and if I enable it, I face exactly the same issue which axis is facing.

axis is it possible that you disable the Slider Revolution Plugin temporarily and check if this works??

Prasant it would be great if you can try to replicate and advise how I can get this moving forward as I wish to use Slider Revolution also in my website :slightly_smiling_face:

Many Thanks.

Hi HimanshuShah,

Please open a new support thread regarding this issue, after creating your own thread, you can add a “Secure Note” containing your WordPress Dashboard login details, so we can investigate this issue.

NOTE: Never add a secure note to your reply on someone else’s thread as all the security notes are accessible to the original thread owner.


@HimanshuShah We will try that and let you know. Otherwise I will work on @Prasant 's instructions and let you all know where we are at with it.


@Prasant I’m a little confused by your first directive. The login credentials we gave you is already for a development site. This is not our live site. Could you please clarify? Thanks.

Hi There,

Yeah, this is getting confusing, let me clarify this first. This is your dev site right? This site has no issue its X and Cornerstone are up to date and its working (see this test page).

And this is your live site now you have an issue with this site because its X (4.3.2) and Cornerstone (3.0.4) version is not compatible.

Normally we will advise you to update the X to the latest version (6.0.4) so they will become compatible with your Cornerstone (3.0.4). But you mentioned above that your schedule would not allow you to troubleshoot the minor issues that will occur if you update the X.

So what I advise for now is downgrade your Cornerstone to the version that is compatible with X (4.3.2). To do this, please navigate to Plugins panel and deactivate and delete the current Cornerstone (3.0.4).

Then navigate to X Addons panel and wait for a few seconds, then navigate back to Plugins panel, you’ll see that a lower version of Cornerstone is re-install, X automatically did that for you and that is the version that is compatible with your X (4.3.2). With this your X and Cornerstone should work seamlessly now.

Remember to clear all caches (plugin, server-side, CDN, and browser’s cache) after downgrading so that the right code from the right version is always in use. This will help you to avoid any potential errors.

If you attempt to update X and Cornerstone in the future and stumble to an issue. Don’t hesitate to create a new thread.

Hope this shed some lights,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.