Cornerstone Not Saving, Website Crashing

Hey there,

This is usually because of poor web host performance or unusual server configurations. Please contact your host to increase the memory and timeout settings. If you can move to a managed WordPress hosting, that would be best.


Thank you for the info, will sure do!

There saying that’s not the issue. Would it be possible to check my site and verify or see if there are any other conflicts?

In this page, I removed the periods in your paragraph and it did save. The intermittent saving issue is usually due to web host issue. Can you confirm they increased your memory and timeout? Also ask them if the have limited your account this past 30 days. You can check your usage in cPanel if you’re using it. If not, please contact your web host.


They are assuring me that it is something with the application, or my network, and I’ve tried 50 different networks, in 50 different areas, I erased my cookies, cache everything. I’m not even using anything heavy, shown in the picture above… Its been very agitating the past couple days, I feel that hopeless, that I honestly don’t know what to do… I just need this fixed, I don’t think that bumping up my plan will change things, but if you really insist and recommend it then sure, can you check one more time? I even tried erasing the custom CSS in the customise area.

Hi There,

Your PHP Max Script Execute Time is set to 90, please increase it to 300. Usually this can be changed through cPanel PHP configuration settings.

Also add the following code into your wp-config.php file which can be located in the root of your WordPress installation.

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add the above code, before the following line where it says:

/*That's all, stop editing! Happy Blogging. */

Let us know how it goes.

I did both and still nothing is happening… Found the PHP Max Script Execute Time changed it to 300, nothing. Imported the script said nothing, what else could it be?

Hi there,

I just tried it and it’s saving, it’s just too long to finish. But I noticed that there many 404 responses in ajax requests. Maybe you host some security firewall (eg. mod_security) and it blocks some requests?

Can’t find what’s causing the 404 but maybe if there are any security logs from your host then we may able to determine it.


I’m using a Mac and Safari, could that be causing any issues, and where should I check?
And for the hosting I will ask them.

Also this isn’t only on my computer or internet, when I go to a different one, the problem persists. Also other developers are having this issue with the website. The only work around I heard was to remove the cache and everything.
Could it be all of the Markers and elements I have on my map on the meetings page that add a lot to the site? I really need this fixed.

It is weird that it saves on my end and my colleague’s. This tells us it could be due to cache but I didn’t see a caching plugin in your site. Did you use a caching plugin before? It needs to be completely removed else it will cause some issues. See for W3 Total Cache removal.

If your web host has a caching system of their own, please contact them to clear and disable it.

Please also clear your browser cache and if you have browser extensions, disable all of them as well.

This is most probably not an issue with markers or other elements because of that is the case, it won’t save for all of us. But, it does save on our end.


No, I haven’t used any cache plugins, all of the plug ins that I used are ones that I currently have. I talked to them and they said they can’t do anything because, it is shared web hosting and it will effect everyone else… what’s to say that if I change my host that this won’t occur again?

Hi there @nagreece,

Thanks for writing back.

Can you test something please, try disabling Polylang and see if the saving then functions correctly. We’ve had a few other reports of saving issues and in each instance Polylang has been used on the site. While we realize you’ll need to re-activate the plugin for your site, it’d be useful for debugging purposes.


I don’t know, but now it worked after I deactivated it again, I tried before maybe its because of the cache, anyways thanks to everyone so much! finally I feel relieved. The only problem, is how am I going to translate the website and have two different menus?

Hi There,

Did you go through our translation guide ? which you can see below.

Hope that helps.

It’s not just an issue with Polylang, I disable it to do changes in the meetings area, and it says that the scripts had difficulty loading and when I try and save something, I get the same issue. I’m going to get WPML in the next few days, but I think there is another issue with the meetings page also. The issue with it not working on other pages is fixed, I can edit other pages create new ones in cornerstone and everything but the specific page, nope.

Here’s the error on that page when Polylang is deactivated

Here are the errors when polylang is active.

I see it doesn’t save unlike other pages. This usually is due to poor web host setup or under powered servers. I know I said that before but I haven’t encountered this in my test sites. Could you try replicating your site in and see if the issue is the same? They offer free development site.


Doesn’t that mean I have to purchase another X Theme License?

You’re right, on the site you gave me I just tested it out, and it works fine! In the link below there were no problems saving. I was looking into changing my web hosting to someone more reliable, which do you recommend? Thanks for the all the help from everyone and Christian, A+ Support!

Hi there,

I would personally recommend our hosting :slight_smile:, but you can try other hosting too. Something that you have full control including caching and security.