Cornerstone not saving parent pages

Hi. I am having trouble with Cornerstone. When I try to save changes to the parent pages on my blog. I get the error “Uh Oh Failed to Save”. Also, when I try to create a new page for my blog, my front/parents pages aren’t showing up in the “parent page” drop down menu.

I am not having trouble saving changes to pages that HAVE a parent page.

For example, I CAN NOT edit but I CAN edit

I am using:
X-theme version 8.0.10
cornerstone version 5.0.1

I have tried disabling each of my plugins one by one, refreshed the cornerstone page and tried to save (using chrome & safari). It’s not working. As far as I can tell, it’s not a plugin issue.

Please help!

Hi Melissa,

Thanks for reaching out.

Since you are done with the basic troubleshooting and the issue still persists, we need to check your WordPress admin. To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Thank you! I just added the secure note. I’m just seeing this reply so I apologize for the delay in getting back to you. I hope you can help! :slight_smile:

Hello Melissa,

I have logged in and tested your Patterns page. There are JS errors on the page. One of the errors generated coming from your custom JS code added in X > Theme Options > JS section. You have added this code:

    async defer

Be advised that you are not allowed to insert <script> tags in the custom JS section.

You will need to install Insert Headers and Footers plugin which is where you can insert the JS code in the correct way. Meanwhile, when you save the page, there is an internal error 500. Can you please enable the debug mode? You can do this by opening wp-config.php and adding

define('WP_DEBUG', true);

/* That's all, stop editing! Happy blogging. */

There should be a detailed explanation about this error message in the debug.log file which can be found in your WP installation folder.

Kindly let us know how it goes.

Thank you. I added that code, deleted my cache and refreshed everything but I am still not able to edit my front pages (home, patterns, etc.).

I was going to delete the JS code you mentioned but I don’t see it there.

What should I try next?

Hi Melissa,

Thanks for reaching out.

I already remove the Global JS mentioned by my colleague for you.

On the other hand, this usually is a server conflict with X. As you can see, there is a status 500 error in the console. That is not detailed though so please contact your web host to check the error logs and fix the adjust the server settings according to what the error log says. You can also post the error logs in a Secure Note maybe we could point you to the right direction.

Hope that helps.

Thank you.

Hi again. So, I contacted my hosting (Host Gator) and I’m being told that the error is because my theme is using too many resources. I was advised to either upgrade my hosting to a VPS dedicated server or ask you guys to fix it on your end. Is there anything you can do to help with this?

Hi Melissa,

There’s nothing much we can do here because the issue is only happening on your install. I suggest that you upgrade your hosting as per your hosting provider advise you.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.