Cornerstone not loading due to conflict on front end of site preventing preview from loading

Hi there,
Am receiving this cornerstone error since updating theme and cornerstone with the site. I have tried removing cornerstone for it to then auto install and that doesn’t appear to have helped.

Is there a known bug that is currently being fixed?

Any help would be greatly appreciated.



I was receiving this error so deactivated plugins one by one and eventually I discovered WP-SpamShield was causing the problem.

I’m not sure what is causing your error message although it may be due to a plugin such as this one.

Thanks Russell - have tried that deactivating a number of plugins and it doesn’t appear to be helping. Even have cloudflare being bypassed completely.

I just saw an X update come through overnight so have updated also all that and nothing appears to have helped.

1 Like

Same here,

since the update almost constantly i am getting this error:

“A conflict on the front end of your site has prevented the preview from loading.”

I need fix ASAP since i have to do a lot of remodeling and i cant work like this.


Kind regards,


Have also the same error when editing the page in a language in cornerstone and when switsching the page to other language got error:
A conflict on the front end of your site has prevented the preview from loading.

Purchased WPML to fix polylang problem but now i got new errors

same here I cannot edit home page any more and all other pages give similar error but some times work. Home page never works. spending too much time on just getting xtheme to work and not getting any real work done.

Good to know am not the only one. Are the X support team working on a fix? Would be great to receive a response.

Hi Nat,

I am seeing the following error when I check Homepage Cornerstone page:

Please try disabling minifying on CSS and JS files. It is already minified by the theme no need to minify it again. Then clear cache after that. Did you also clear cache after plugin testing?

For others, we are sorry you’re having the same issue. Though due to different setup and configuration on each of your site, the root cause might be different for each of you. If you have done the basic trouble shooting which is plugin conflict test then clearing cache after that, we do advice to please open a new thread. We would love to help you solve this, but we need access to your site. After opening a new thread, share site URL and credentials on a SECURE NOTE. It is not recommended to share it here because the secure note content is visible to original posted of the thread. To also avoid more back and forth, please state on the original message the basic troubleshooting that you have done on your site already. Thank you.


I’ve got exactly the same problem after recent update. Can not edit ANY page.

Waiting for your helpful hand.


Hi @quanto

If you have any cache plugins, please flush the cache.

If the issue persists, please try turning off all third party plugins in order to test for plugin conflict and try it again.

If that does not help, please open a new thread, explain your situation in detail and provide your WP Admin credentials in a secure note.

Thank you

1 Like

Same issue here. I’ve tried turning off all plugins, and flushing cache. Will submit a support ticket as I don’t see any resolution here.

Hello There,

Thanks for updating this thread. It would be a good idea to have your own thread.
We will be responding your new thread shortly.

Best Regards.

Hi Lely,
Thanks so much for your reply. I think I have turned this off however it doesn’t seem to have fixed the problem. Am not sure what I am missing with this?


Hi there,

I accessed your website and added a new page and added an alert element. Then saved and it was working ok in the front end of the website When I came back to edit there were no elements.

I tried to deactivate all 3rd party plugins except Cornerstone to test for possible 3rd party plugin conflict but unfortunately I encountered this:

Please kindly try to deactivate the plugins except for Cornerstone one by one and check the case. Kindly get back to us with the result of your investigation.

Thank you.

HI Christopher,
I think I found the problem plugin finally - it looks to be the “Pin It Button for Pinterest” that is causing the conflict which is rather weird as it has been in the website from the beginning. Am guessing something has changed with the new cornerstone update to cause the issue. Have deactivated for now.

I too have experienced this on my most complex page with lots of elements. I’ve managed to get it working by refreshing and flushing the cache and Cloudflare (I’m with WP Engine). For me it was intermittent rather than constant.


Glad to hear you found the problematic plugin.


In case you are still facing issues, please refer to this article:

Thank you

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.