Cornerstone not loading but posts appear in View mode fine

I just updated to the latest version of X and Cornerstone. I have also updated Wordpress. I cleared my W3 cache and cleared my Web browser. I already have this setting in my wp-config.php:

define(‘WP_DEBUG’, false);

define( ‘WP_MEMORY_LIMIT’, ‘512M’ );
define( ‘WP_MAX_MEMORY_LIMIT’, ‘512M’ );

Everything on the site is working fine except for this:

When I choose to edit an existing post in Cornerstone, the post opens but then the Cornerstone logo just keeps spinning (well, throbbing) indefinitely. So I can’t actually edit any of my posts. None of the content appears. However, the content does appear if you look at the posts in “View” mode. What should I do to fix? Thanks.

Hi @pearlmultimedia

Thanks for writing in! please try the following:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  3. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  4. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  5. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

If this didn’t help, then please provide us with WordPress Dashboard login details in a “Secure Note” so we can investigate this issue.


Is anyone else having this problem just because they updated X and Cornerstone? The only reason I just upgraded is because my mobile menu stopped working. The last time I tried updating both it broke my site. And I have five sites using X so I need to get this fixed now…

Update: I just deactivated W3 Total Cache and Cornerstone now works.

What’s the solution here? How do I get W3 working with the current X and Cornerstone?

Update: I just reactivated W3 and Cornerstone isn’t working again. So this is definitely the problem. Maybe it’s some W3 setting that I set incorrectly?

Update: In W3 I just told it to never minify these JS files, based on another support ticket. But it hasn’t helped my problem:

Hey There,

Could you please confirm that you have updated to the latest versions?
Our latest versions are:

  • X theme 6.1.6
  • Cornerstone 3.1.6

This latest release contains fixes for several issues so be sure to check out the changelog (

_After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.-

If everything is already up to date and you are still experiencing the issue, would you mind providing us the url of your site with login credentials so we can take a closer look?
To do this, you can create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

Please let us know how it goes.

Yes, I just added the login info to my previous comment on this thread. Thanks! I’m desperate to get it fixed on all my sites asap.

Hi @pearlmultimedia,

There is an option in W3 that will disable the minification for logged in users. I toggled it on and the builder now loads on my end.

There is no need for minification for logged in users.


Thanks, Rad!!! You rock! I’ll go ahead and make that change on my other sites as well. Have a great day.

Thanks @pearlmultimedia for updating the thread, you are welcome :slight_smile:

Hi! I followed the same steps on my other sites with X. Now I’m going through and checking. On one of my sites Cornerstone has completely disappeared as an option for editing posts, even though the plugin is up to date and is activated. Any idea why?

Hi @pearlmultimedia

Check under (X > Settings > Permissions) and make sure “Posts” is selected:

To learn more about Permissions in X theme settings, please check this guide:


Yes, that worked! Thanks. I’d done it but forgot to click the Update button top right. Thanks, Alaa.

You are most welcome

Well… Now I have another problem with Cornerstone on the same site. When I look at a post in Edit mode, it looks fine (correct font sizes and colors). But in preview mode it all changes. Why is that? It’s like it no longer recognizes the Global CSS I added to correct this a while ago… And it looks ridiculous! This is for Classic Text boxes, the H2 etc heads. It’s making them 63 px instead of 26 px. Help!

Hi @pearlmultimedia

I can’t log in with the previously mentioned credentials, could you please recheck them?

This could be an error in the CSS syntax you added in Theme Options, I recommend validating the codes added there using this tool.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.