Cornerstone loading forever

I am trying to edit my pages through cornerstone but none of the pages are loading. All I see is the spinning gear.
I have tried the following:

define( ‘WP_MEMORY_LIMIT’, ‘256M’ );
define( ‘WP_MAX_MEMORY_LIMIT’, ‘512M’ );

to my wp-config.php file but the error is still present.

Hi There,

Please confirm you have PHP 5.6 and superior.

If the issue persists, please try turning off all third party plugins and test again.

If the issue persits please provide your WP Admin credentials in a secure note so we can take a closer look.

Thank you!


I have checked and the php version was at 5.3 and upon changing to php version 7.1, the problem was still present and cornerstone was still unable to load while loading forever.

Here are my wp-admin credentials:

Hi There,

Please try turning off all third party plugins and test again. Seems this is a plugins comflict issue, you can reactive one by one after test this.

Let us know how it goes.



I tried disabling third party plugins one by one but the problem is still present.
Please advise.

Thank you

Hi there,

There could be many possible causes, the first one is caused by CORS. You have configured your site admin to use secured URL (HTTPS) while the front is non-secured (HTTP). Cornerstone builder is mixed with both backend and front end, and this setup of yours triggers the CORS issue.

Since this is live, I can’t disable your HTTPS plugin because it usually breaks a site when it’s dependent on the plugin. These are my recommendations

1 Don’t use plugin to enforce SSL/HTTPS on your site (it may skip internal URLs)
2 Configure your two URLs in Admin > Settings > General for HTTP or HTTPS at the same time (to make sure backend and frontend uses HTTPS)
3 Install Better Search Replace plugin and replace this string

with this

of course with your own domain name :slight_smile:

Let’s do that first to fix your site’s CORS issue, I’m not saying this is the final cause/issue but we need to eliminate them one by one.

I also flushed your site’s permalink and seems it fixed the CORS issue, but make sure to follow my recommendation to prevent future issues. Now, the error being display is 404 error and internal server error on both cornerstone endpoint. Please provide your FTP login credentials as well for further checking. Looks like it’s trying to switch from current cornerstone endpoint to legacy cornerstone endpoint due to 404 error. Plus, if you host has security feature like mod_security then please disable it first while we’re investigating.


Hi I have followed your guidance and installed ‘‘Better Search Replace’’ and have done the necessary changes
(from to

Could you please check if it was done properly ? I am sure I ran it but It would put me at ease if you could double check.

Thank your for assistance!

Here are the requested FTP login credentials:

Hi there,

Please check the secure note



It works now!
As for the eror 404, the hosting provider suggest I add the following line in my .htcaccess within my ‘‘59connect’’ subfolder:

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off

Unfortunately, I am still unable to display the cornerstone endpoint page.

Would you have any suggestions ?

Thanks again

Hi There,

I can access your page is Cornerstone (, but I still get the errors that Rad mentioned above. Would you mind setting up a child theme and follow the solution provided here.

How To Setup Child Themes

Hope it helps,

Hello There,

You have withdrawn your post, did your issue already resolve? Please confirm.



I have mistakenly put this line of code in my main theme’s function.php and am now unable to access any page on my website with error 404 displaying

function remove_polylang_wpml_filter_from_cornerstone() {
  add_filter('wpml_active_languages', '__return_empty_array', 999 );

add_action( 'cornerstone_before_boot_app', 'remove_polylang_wpml_filter_from_cornerstone' );

Is there any way to revert this issue ?

Hello @59connect,

I couldn’t find above code in your function.php file. However upon deactivating Polylang plugin, your website seems to be working fine.



Yes, I removed the code lines from function.php after I saw the issues with page 404.

The website works but upon clicking on a link, it will bring to page 404. Also, I am now unable to edit any pages with cornerstone as it will also bring to error 404.

Please advise

Hello There,

Did you resolve the issue? I have checked the page and I can edit Cornerstone with no issues.

For your 404 issue, please update the permalinks. Go to Settings > Permalinks and simply hit the “Saved Changes” button.

Please let us know how it goes.


Thank you so much for your assistance, it works now!
Now that polylang does not work with my website, is there a way/plugin that could help with switching languages throughout the website ?

Thank you again

Hi There,

You can try WPML plugin.

More info here about Translation.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.