Cornerstone editor not working correctly

Hi there, I am having another issue with Cornerstone. The page is not loading correctly. The code shows up and then when you scroll WAY down the page you get to the “edit with cornerstone” button. I’ve had this issue before and the page will eventually break completely. Can you take a look and see what you can find? I just created a NEW page and copied the content template into it and the error is happening again but I can’t see where any content is broken. The new page has NOT been edited with anything other than cornerstone.

I’ve gone through your initial checklist. tested for plug-in conflicts. Switched theme from child to Xtheme. Themes are all up to date. Disabled and cleared cached.

Any help would be MUCH appreciated. All the best, Cindy

Hello @cindywho,

Thanks for writing to us.

There might be a few different reasons for this issue, I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing for Plugin Conflict
  2. Child Theme Issue
  3. CSS/JS Customization
  4. Disabling Cache

If none of the above help, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


Hello Cindy,

I checked your website Dashboard, It seems that there might be a cache issue, I went ahead and clear the cache and builder are working fine. I would recommend you to purge all the cache and then clear your browser cache as well then check it again.

If the issue still persists please let us know with making a screenshot


HI again - Thank you but I had already cleared the cache. The issue is still happening. The page itself is currently displaying correct but please click on EDIT and you will see what I am talking about. a HUGE list of code shows up and then at the very bottom the “edit with cornerstone” button appears

Hi @cindywho ,

Sorry for the confusion, this is a known bug and you can temporarily fix the issue by adding the following code in the child theme’s functions.php file (see

/* Temporary fix for Gutenburg issue with WP 5.4 */
add_action('admin_head', 'fix_content_builder');

function fix_content_builder() {
  echo '<style>
    .cs-disable-gutenburg #editor .edit-post-visual-editor.editor-styles-wrapper {
      display: none!important;

This will be fixed in the next release of the theme and then you can safely remove the above code.

Hope this helps!

Nabeel, thank you! This has been driving me crazy. I submitted a ticket for this issue on another page and did not get this help. It would be helpful if the entire support staff was aware of this issue. I’ve installed the above code as directed and the site is back to functioning correctly. Much appreciated! Thank you again for the quick and helpful response.

Hi @cindywho,

Glad to help you.

Have a nice day.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.