Cornerstone - caching issue


I am getting the below error while trying to edit my page via cornerstone, which used to run perfectly before…

The preview could not load. This is most often related to a plugin conflict or aggressive page cacheing. Checking the developer console for errors could indicate what went wrong.

I have the latest version of X, i have tried to disable plugins one by one and tested, in case there was a conflict as suggested. No luck there…

I dont know how to check the developer console… By the way the page url is not opening when i type it in the browser either, i get the error “page not found”, despite i can see it is available in Wp-admin…

So i am quite stuck now. I have seen similar entries before submitting this but could not find a relevant solution…

Any help is appreciated, many thanks.


Thank you for reaching out to us. This is the most generic of all the error messages and can be caused by multiple factors, namely syntax errors in custom coding, aggressive caching and finally security rules. it is known that Siteground blocks the required resources from being loaded, if you’re using Siteground hosting then you’ll need to contact Siteground and ask them to exclude the resources from their mod_security rules. Please check for the following first:

  1. Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.

  2. If you’re using a caching plugin, clear all caches including browser cache then deactivate your caching plugin and other optimization plugins.

  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

  4. If you are using SiteGround, could you please disable the supercacher in your hosting panel? You can access the tool by clicking on the SuperCacher icon in your cPanel.

  5. The other thing which is usually the problem cause is related to the Mod_Security setting of the server. Please kindly check this guide for more information regarding that The Mod_Security rules should be excluded from Cornerstone assets.

  6. Remove custom CSS, JavaScript and deactivate your child theme and switch to parent theme (take a complete backup first).

  7. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

  8. Contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php (please see

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

Also please check, and

Let us know how this goes!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.