Content dock has no content on pages other then homepage

Hi,

I’ve configured Content Dock to show content on every page and post. On the homepage, it works perfect. But on other pages it appears, but without content. What’s going on here?

This is what’s shown on all pages except the homepage; the homepage works fine:

Disabled caching and plugins, just to be sure, but that’s not resolving the issue.
I’ve added a secure note with credentials to check the live website.

Hello @dhunink,

Thanks for writing in! I wasn’t able to replicate the issue on our local testing server. Could you please temporarily deactivate all the WP Rocket plugins? We want to investigate the issue without these plugins being active. It would also help if you could clone this site to a staging site so we can do the troubleshooting on the staging site without affecting your live site. You might want to check this article to learn how to clone the staging site:

Best Regards.

Hi @ruenel,
thanks for getting back to me. I’ve created a staging environment and will share the URL in a secure note. The credentials are identical to the ones shared in the initial secure note.
On the Dev-site, WP-Rocket is disabled, but the issue is still there.

Hey @dhunink,

Thanks for updating in! Did you happen to edit the plugin and added this broken HTML code to the Content Dock output code?

<div style="border:2px solid #84666a;position:relative;">
			<div style="font-size:12px;padding:1px 4px 1px 6px;float:right;background-color:#84666a;margin-bottom:2px;color:#FFF">tco-content-dock</div>
				<div style="clear:both"> </div>
		</div>

I would recommend that you deactivate the Content Plugin, delete the plugin, and reinstall it again.

Kindly let us know how it goes.

Hi @ruenel,
I don’t remember editing the plugin. I actually would never do that. But just to be sure, I removed the plugin and reinstalled it. That did not resolved the issue i’m afraid.
I can see that the HTML-code you posted is invalid, but I don’t see where it’s coming from. I’ve double-checked my child-theme, and it’s not coded there.

So far the main clue I’ve got is the content of the widget is retrieved from the DB on the homepage, but is not on any other pages. Can we debug that some more perhaps?

Hey @dhunink,

I can’t seem to log in to the site anymore. When I open it, I see this:

  • See the secure note.

Please check the debug_log for errors.

Thanks.

That’s fixed, sorry for the inconvenience

Hey @dhunink,

I still cannot log in to your staging site. When checking the main site, is it possible that we temporarily disable the Pages by User Role for WordPress plugin? This could be the one causing the issue. I have double-checked all the possible files that might contain the code I pointed out in my previous reply. I still cannot find it.

Thanks.

Hi @ruenel,

totally my fault. I was using the same dev-env as preparation of a PHP-upgrade, which made it impossible to login. But that’s fixed now, and you should be able to login now!

On the dev-site i’ve disable User Role for Wordpress. That made no difference regarding this issue tough.

That login is redirecting us to a page I’ll post in a secure note below. Do you want to send us a screenshot of what content you are using in the widget area? Have a great day.

That’s correct. But you will see the admin-toolbar, and can access the wp-admin area through that toolbar?

I don’t see the admin toolbar and it just redirects me to page I posted in the secure note when trying to login. It kinda feels like redirect issue? The dev login url actually redirects to the main site too. Let me know if we’re reaching the wrong page or something.

You’re right, something was going on for IP’s that weren’t white-listed.
I’ve been able to fix that by changing the login-url and updated the original secure note.
Sorry for the inconvenience; that’s not helping to speed up fixing this issue.
I hope we can speed things up now :grinning: