Content Builder in Pro not working

Hi ThemeCo,

I upgraded to Pro from X Theme and found that content building stopped working.

I thought this was a Cornerstone issue, but I now understand the content builder is what creates and edits pages in Pro.

I get a spinning wheel when I try to access, edit or create anything using the content builder.

Is there a troubleshooter for the content builder?



Hi Steve,

Actually, you do not need the Cornerstone anymore as you already converted to Pro. The Pro theme has it’s own Content Builder which is exactly like the Cornerstone and in addition it has the Header and Footer builders.

Whatever page that you created using the Cornerstone will work the same and you can edit them using the Content builder. Just go to the page and you will see the button to enable the builder.

Click here for more information about the X to Pro conversion.

Thank you.

So that content builder isn’t working.

I just get a spinning wheel when I try to edit a page, or any of the headers, footers, templates.

Hi Steve,

Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. If you’re using a CDN(ex: CloudFlare), please clear the CDN’s cache and disable optimization services. For the CloudFlare you also need to follow the steps below besides the developer mode:
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Switch to the parent theme to check if the issue persists.
  7. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  8. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Thanks Chris,

Are all of these steps the same for Pro?

Thanks again,


Hi Steve,

Yes it is the same for PRO Theme.

Thank you.

It does look like something in the settings of W3 total cache is the cause.

I went to a backed up version of the site in X theme and found cornerstone wasn’t working in that. Turned off W3 Total Cache and Speed Booster and cornerstone now works.

I did try turning off W3 total cache in Pro, but that didn’t seem to fix the problem.

I’ll try upgrading to Pro in this and see if works and then follow the instructions for setting up W3 total cache.

I upgraded to an earlier version of Pro, think it was 2.0.4, and content builder worked fine (W3 total cache and Speedbooster not activated).

Then I upgraded to Pro 2.2.5 and the content builder doesn’t work.

If I click on the clear style cache button, it doesn’t come up as completed, instead a blank page is displayed:


Is this a known issue?

Hi There,

Thanks gain cor confirmation!

Can you please send us following details? so that we can have a look.

Set it as Secure Note

  • Link to your site
  • WordPress Admin username / password
  • FTP credentials
    All the best!

I’ve been back using 2.0.4 and content builder worked fine when W3 total cache and speedbooster were disabled.

I’ve tried again upgrading, this time to the latest version 2.3.5 and I’ve got the same problem as with 2.2.5 of the content builder not working.

If I click on the clear style cache button, it doesn’t come up as completed, instead a blank page is displayed:


What I’ve done so far:

  • W3 total cache and speedbooster are disabled.
  • PHP increased max memory to 256mb (from 32mb) - checking with host if I can get to recommended 512mb
  • PHP Max Script Execute Time to 250s.
  • Edited wp-config.php - define(‘WP_MEMORY_LIMIT’, ‘512M’);
  • Running the parent theme

What I haven’t done yet:

  • deactivated all plugins yet.
  • removed the Google Tag Manager JS
  • reset access to htaccess file

Hi Steve,

I have re-activated your W3 Total Cache plugin, then disabled CSS/JavaScript autominifications from caching settings, purged server cache. Then I was able to load the content builder without any issues (see secure note).

Could you please confirm on your end as well.


Hi guys,

No change at my end, until I tried it in Chrome Private mode and it works perfectly.

Cleared browser history in normal window and it works.

My next step is try and speed the site up.



Glad to hear everything is working now.

Please note that you don’t have to activate the CSS/JavaScript autominifications option. All the JS, CSS files in Pro theme have been minified already.


When I’ve done that it seems to speed the website up (checking with website grader).

I won’t do the he extra minification, but I will look at other ways to speed it up.

Dumb question - how do I remove or defer any Javascript?

I’ve tried lots of different options and get stuck on this:

Render blocking	-	Remove or defer any JavaScript or CSS that interferes with loading above-the-fold content.


Hi Steve,

We actually don’t recommend deferring all JS files on your website, not all the scripts can be loaded in the footer. Some JS files require certain libraries to be loaded first, so altering the order of loading of such files might cause different problems.

To improve your site speed kindly refer to the link below for your guide

Hope that helps

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.