Changing fonts doesn't work

Hi guys I am trying different fonts for my content body however I realized that no matter what I select, it doesn’t change it.
here 2 screen shots…

do you have an idea on why?

thanks a lot cheers
Isabella :slight_smile:

Oh forget about that. I understood why. those that I selected are not in the system but just in google.
no problem. I have chosen one already in the system

However something wrong it’s happening.
So in the back end editor it’s like this. ( which I like )

whereas in the front end is like this

which I don’t like

I purged all the caches…
what’s wrong?

thanks a lot for your help

Hello There,

Thanks for writing in! I would recommend that you temporarily disable all caching and minifying plugins in your site so that you can easily see any changes that will be made in the theme options, edit preview and in the actual live site. And right now I am seeing a CORS issue in your site. Some of the files like fonts and images were loaded from and this is also the reason why you are seeing squares icons in the site.

Please let us know how it goes.

Hello @RueNel
thanks so much for getting back to me.
I don’t really understand you sorry.

How do I do that?
do I actually need to deactivate all the plug ins??? this is so much time consuming…

what is stactkpath ? I never loaded anything from there…

I am not seeing icons? are you?

thanks for the clarifications
cheers :frowning:

Hello There,

  • You only need to deactivate your caching plugin and minifying plugin if you have installed it.

  • When I view your site, I am seeing this: could be a CDN cache in one of your caching plugin or plugin that optimizes file resources.

Hope this explains it.

@RueNel I appreciate your infinite patience but I don’t understand how to do it.
Now I can see it correctly no more square symbols but the font is still wrong.

thanks a lot again for clarification
cheers :slight_smile:

Hi Isa,

I went to your website and accessed X > Theme Options > Typography. I enabled the Font Manager feature and set the body text to body copy and the heading text to heading.

Then I clicked the cog icon at the bottom left section of the screen and selected thefonts tab and assigned proper fonts for the body copy and the headings:

Click here for more information about the Font Manager and how to use it in X theme.

Thank you.

@christopher.amirian I don’t understand why would you change the fonts. I didn’t want that.
The font I selected was what i wanted.

Did you read the tread? you reply doesn’t have anything to do with the previous conversation

I am confused now.

Can somebody help me please?

Sorry that my answer was confusing. From what I read from the back and forth the problem was the fonts. The reason I changed thefont was to show you it is working with no problem. Would you please give us the body and heading font that you like and we will change back to the original one.

Also, please get back to us with the exact request at the moment as my impression was that the problem was the font.

Thank you.

the problem was that the font I selected was showing in the back end but not in the front end.

I entered where you told me to enter and I change it.

So I changed back to the font I wanted but I have the same problem as before. In the back end it works and in the front end doesn’t show

see screen shot of the back end ( the correct one)

but if you check this link it’s a different one

Hi Isa,

I checked both the backend and frontend of the website and both use the Canadra font for the header and Goudy Old Style for the body text.

It seems that the problem is your browser. Please clear your browser cache or check the website with another browser or computer as I see both of them working as the same font.

Thank you for your understanding.

ah ok ok great
cheers :slight_smile:

You’re welcome! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.