Can't install Font Awesome above v. 4.04

On some of my forms, like at, I have a conditional field in the third column for “WHICH BRANCH?”. By selecting any of the branches, a hidden field in the 4th column appears. This brings up a locked field showing a travel date, and before I did a major update to this site last night to the theme, PHP and WP version, it used to show a Font Awesome LOCK icon. It worked perfectly fine before last night’s update.

What I’m noticing is that I can’t upgrade to Font Awesome 5.14. I feel I have tried numerous suggestions I’ve found online, including a couple I found in this forum. I’ve tried using the CDN setting with v4 compatability checked. The API setting. But nothing has worked.

Below are screen shots of the settings. The last one shows that I am using the correct HTML value for the lock icon as per Font Awesome’s site. And like i said, this was working yesterday before the theme updates I did last night. Any suggestions?

I enabled Font Awesome’s conflict detector and it called out this error: Notice : Undefined variable: should_enable_icon_chooser in /home1/s9z4q6n4/ on line 1623

I went to line 1623 in the php file it calls and this is what I see…

Hi @ppe29,

Thank you for writing in, your input field is set to use your site default font-family to Source Sans Pro

And that font has no idea what are those unicode you put on the placeholder so it’s not going to render any icon.

You need to use a custom CSS rule that applies a font-family: 'FontAwesome'; to those input fields, but by doing this you need to accept that those input fields will not be going to have the default Source Sans Pro .

Hope it helps,

But it worked before, for months.

Hi @ppe29,

There could be an update and some changes with the plugins that’s why it is not working at the moment. I suggest that you follow the suggestion given by my colleague.

Hope that helps.

I was able to figure this out with this bit of CSS:

.fontAwesome::placeholder {
font-family: “Font Awesome 5 Pro”;
font-weight: 900;


Glad you sorted things out,


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.