Can't find my Typekit Font in Typography

Dear Support,

Recently i bought a Typekit font so i could use it on my site. I followed all the steps laid down on the following page: I just can’t find the font when i search it in Theme Options > Typography.
Website URL:

Am i missing something?

Best Regards,

Fedde Westera

Hi There,

Thanks for writing in!

Please check this thread for a possible solution!



Looks like the issue in the linked thread was that the site was not verified. I have completed this step on my site.
I have:

  • Installed the Typekit Plugin

  • Enabled Typekit

  • Place the Font into a new kit

  • Added my website to this kit

  • Added the Kit ID into my Typekit Plugin

My fonts are displayed in the Typekit Plugin in the “Kit Information” tab. But i can’t find my fonts in the Theme Options > Typography

Is there a step that i am missing?

Best Regards,


Hi Fedde,

You could try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

If it still doesn’t please provide us your wordpress admin login in Secure Note so we can take a closer look.



Thanks for the fast reply. I’ve tried deactivating all my third party plugins, but nothing has changed.

Hey Fedde,

Sorry for the confusion. You should setup Typekit in the Font Manager (also see the secure note).

The instruction in our Typekit extension article is only applicable for older theme versions.


Awesome! Thanks a lot!

You’re most welcome!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.