Can't Find Fonts Google Page Speed is Complaining About

I have added this code… it doubled the load time…

This is the site…

In the HTML source, I do not find where the fonts are and I really would just like to remove them.

Hi @verobeachmarketing,

The Font showing in the Google Page Speed is a part of the theme and loaded through the CSS files and can’t be removed.

Thanks for understanding.

Could I not remove it in the child theme? Can you tell me where it is used on the LIVE website?

Hi @verobeachmarketing,

You can’t remove it in the child theme and it is not advisable to remove it because it is needed with the icons. You can check this article on how you can fix the preload key requests.

Hope that helps.

Thank you.

I removed the font files it made the load time worse. I removed the two fonts from the three CSS files and then more showed up with the same issue. Pro Theme still worked fine. I restored all of that.

I have also tried two methods for preload, another I found and the one you referenced…

It does not improve.

I understand that the fonts are required for the backend, but I do not understand the front end. I am not using these fonts for my site design so why are they being included and slowing down my site?

Hi @verobeachmarketing,

Even if you haven’t used the fonts directly, the fonts are used in the pre-defined classes in those CSS files and that is why the fonts are loaded.

Thanks for understanding

I don’t understand. The font is not needed on the front end. Therefore I want to remove it. I grep all files and found it in 3 files and removed it, cleared cache and still the files are being requested. I do not understand where it is coming from and how to remove it so that the site will load properly. At the very least I would like to change the paths to the CDN etc.

Hello @verobeachmarketing,

To better assist you with your issue, kindly provide us access to your site so that we can check your font settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Hey @verobeachmarketing,

Try disabling the Font Awesome families in Theme Options > Miscellaneous.


Those are the only Font Awesome fonts in our themes. If the WOFF font is still loaded, it’s most probably coming from a 3rd party plugin so you must test for a plugin conflict.


It worked. Thank you for this. Seems like fonts should be not in MISC and under the fonts but now I know.

You are welcome @verobeachmarketing

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.