Can't edit pages using Pro

I have the latest version of Pro & started making just a cover page to leave up. I’ve deactivated plugins, & tried multiple browsers, & cleared my WP cache.

I get the endless turning wheel whenever I try to edit any pages. Plus I can’t upload any new pictures.

Hi @onlyonce ,

Thank you for writing in, please do the following first:

  • Ensure that you are fully up to date. WordPress, Theme, and Cornerstone (Version Compatibility)

  • Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  • Are you using SiteGround’s Optimizer? If so, please clear its cache and deactivate it for a while.

If the issue persists, please provide us login credentials on a “Secure Note” so we can take a closer look.



It starting working again today, now is just quit accepting uploads again. I will check with GoDaddy.

Hi @onlyonce,

Did it just start working again suddenly without you doing anything? If so, that is more likely a server-side issue. Yes please contact your hosting.


My service provider attempted to trouble shoot it, so did GoDaddy.

It seems to have been on the side. It was really strange. I could edit one site using Pro totally fine. Yet the other site was completely failing at the Wordpress dashboard level to load Pro editing, & suspiciously unable to upload any new media as well (found this out when I tried to at least get the images uploaded). Everything else on the WP dashboard seemingly worked perfectly fine. Yet no topics suggested testing this when we are facing a failing to load Pro editing.

So if you are having issues with an endless spinning wheel, I would STRONGLY suggest, attempting to upload media from the WP side instead of the Pro interface. If you are like me, that won’t work & you may have to wait for WP to solve whatever problems they are having.

Without testing the media uploading, I would of continued to think it was a a Pro issue, because no other topic suggested testing the for media uploading ability. Everything else in the main dashboard worked as normal.

Hello @OnlyOnce,

Have you tried uploading a small file size? It could be that you have a limited PHL max upload. Please go to Tools > Site Health > Status and make sure that there are no performance issues. If you go Tools > Site Health > Info > Server and check the Upload max filesize and PHP post max size is at least 32M or 64M. In my example, I have set it to 800M so that I can easily migrate sites since this is a testing server.

If ever in your site, the setting is only 8M or 16M, this will also affect when editing in Pro. We would love to check your site as well if you allow us to. You can create a secure note in your next reply with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.