Can't edit page on Cornerstone

Hi team. I’m seeing the attached message when I click on edit page on Cornerstone. Please let me know how I can fix this. Cache was cleared. Thanks so much. R

Hi There,

Thanks for writing in! Most probably you’re running out of your server’s allocated memory. First of all, try re-generating your permalink settings and see if that is related to your .htaccess file.

  • Check your permalink settings (General -> Permalinks) and set Postname save changes to re-create your .htaccess file.

Then try increasing your PHP Memory limit by editing your wp-config.php file which can be located under the root of your WordPress installation.

Add the following lines into that file.

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

Check the following as well.

  • Make sure that you’re running at least PHP v5.6.x or later to avoid any WordPress related incompatibility issues. If you’re not sure what your server configurations and settings are, install a plugin like WP-Serverinfo ( and check your server info by head over to Dashboard -> WP Serverinfo area.
  • Check your PHP Max Execution Time and set it for 300 for optimal usage.

Further, our troubleshooting guide here (

Let us know how it goes.

Hi team, so ‘postname’ is already saved in permalinks. I’m stuck at your next instruction on 'increasing PHP Memory limit. I’m not very tech savvy so would be great if you could make this easier for me to understand. Where can I find ‘the root of my WordPress Installation’? Also, where can I find ‘PHP Max Execution Time’? Thanks so much, Ramona

Hi There,

Root directory would be the place you install WordPress. Usually it would be inside public_html directory when you connect through your FTP. Follow this guide for more information (

You need to edit PHP.INI file to increase max execution time. Please refer to the following resource for more information (


Ok… I’ve done everything you’ve said…

  • Memory limits are updated
  • Current version is 7.0
  • Max execution time is set to 300
  • Cache purged
  • Cache plugins deactivated
    I’m still getting the error message. What else should I do?
    Thanks, R

Hi There,

Thanks for writing in!

Would you mind providing the website details so that we can have a look?
Please provide following information:
Set it as Secure Note

  • Link to your site
  • WordPress Admin username / password
  • FTP credentials

meanwhile, you can try few troubleshooting processes.
As I do not have access to your website dashboard I will suggest few troubleshooting steps that you should follow, you already followed few of them which I will not include anymore:

Incorrect setup of SSL. If you have an SSL certificate on your site. You should have the WordPress Site URL and Address URL settings set to HTTPS if you are loading the builder via HTTPS. This can be checked via your wp-admin > general > settings. If you aren’t using SSL you can ignore this step.

Cloudflare. If you are using Cloudflare please disable this for testing purposes. Cloudflare by default enables an auto minfication function to compress the JS and CSS files of the theme. As the theme already serves minified files, re-minifying said files only causes to break the entire site.

Custom code syntax error. If you have a child theme, please enable the child theme and check if the issue still exists. If you have entered any custom JS or CSS into their respective editors. Please review the code for any syntax errors. A mis-placed semi-colon or a missing bracket will cause the issue you’re seeing.
If you could please try the above and if you still have the issue we’d be more than happy to assist.


I’ve provided details in a secure note in my last message. Thanks so much. R

Hi @fitnizfury,

Would you mind setting the user profile as admin because I could not check your setup further.

You could also check for plugin conflict because I could see errors in your console.

You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Let us know how it goes!


Hi I changed to admin. Would you be able to check please? Thanks. R

Also disabled 3rd party plugins but no change

I’m sorry but when I tried to log in your website I got this message from Wordfence plugin:

INSECURE PASSWORD: Your login attempt has been blocked because the password you are using exists on lists of passwords leaked in data breaches. Attackers use such lists to break into sites and install malicious code. Please reset your password to reactivate your account.

Could you please reset the password and make it stronger? or disable this option in Wordfence for now till we finish investgiating this issue.


done… pwd sent to secure note on my previous message

Hi @fitnizfury,

I could see this error in your browser console when opening the front page cornerstone.

Failed to load Request header field X-Requested-With is not allowed by Access-Control-Allow-Headers in preflight response.

In this case, contact your hosting provider and see if they can disable the security or exclude that URL and all requests (all payload related to that URL ) from your security rules.

Let us know how it goes.


Hi team… Bluehost informed me that the issue is with the ‘Cornerstone plugin’. I can’t deactivate it cos my home page and some others are created through this. This is what Bluehost asked me to forward to you…
“You would need to contact theme vendor and ask for the requirements, so that we will be able to figure out whether your theme meets up our server requirements.
also please contact plugin vendor and check why you get this error when you use the plugin”

Please advise

Hi R,

I’m not really sure on which page Cornerstone isn’t working? I’ve tried it on the homepage and I can see it’s working fine at my end, please check this screenshot:

I’ve added an extra dot there. Could you please try clearing your browser cache and recheck this issue?


My home page. I’m still getting this error message when I try to edit it on cornerstone.

Hi there,

I could reproduce the problem and it is indeed a server related problem. I wonder how they concluded that the problem is from theme? Did they give you a result of an assessment?

Here is an error I get in my browser console which indicates the problem is the Access-Control-Allow-Headers policy that they have (Please check the secure note).

I am not sure where is the settings in Bluehost you need to communicate with them.

Here is what they sent back…
When you tried to change the theme and checked , still got the error ? because when I checked now , it was an issue with that plugin also and theme will be included

Because some time the sever requirement needed for the theme and plugin is not set with the website version which cause the issue

So you need to ask the theme provider and check once what are the server setup requirement they need for the theme and also let them check the theme version with the website version and see if that is adjustable , if that works , then it will be fine

In that , please check this point ‘’ Access to Font at ' ‘’ which shows the issue with the files of that plugin called ‘’ cornerstone ‘’ , so that plugin , need to be checked by plugin vendor

And they can able to check that plugin files

Hi there,

That’s a CORS issue, the file is being loaded in HTTPS enabled site but served to HTTP (not secured). It’s not related to cornerstone or the theme since it only uses the URL provided by Wordpress. Your Wordpress URL must be configured correctly for it to work.

One thing I noticed is that your page is served through HTTPS but your URL configuration is still in HTTP under Admin > Settings > General. Please note that those URLs are used internally by Wordpress, if you prefer using HTTPS then configure it for HTTPS. Don’t use any plugin or redirect just to make it HTTPS, it must be configured internally too.


FIXED… FINALLY!! Thank you… can’t believe I wasted 5 days on something so simple :slight_smile:
Thanks again!

1 Like