All anchor links stopped working

Not working in X-Theme or Pro. All versions up to date including Cornerstone. Please advise

Hello @6stringlove,

Thanks for writing in! After doing the updates, always remember to clear all caches since you have installed WP Fastest Cache plugin so that the code from the latest release is always in use. This will help you to avoid any potential errors.

And please clear your browser cache too. You may use private browsing mode in testing your site to make sure that you are viewing the latest codes from the updates and not the cached version in your browser.

It could also be caused by a plugin conflict, amongst other things. Please check out this troubleshooting article here and follow the instructions for the following sections (where appropriate):

Testing for Plugin Conflict
Theme Update
Child Theme
CSS/JS Customization
Disabling Cache
Disabling CDN

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

EMptied and disabled cache and anchor links still not working. The anchor links are located under the Services link in header navigation.

Hello @6stringlove,

I checked your site it seems that all the links are working. Please have a look at the video in the secure note. It might be the issue of cache issue at your end. I would suggest you clear your browser cache and then check it again.


Still having same issue. Deleted the caching plugin. Cleared cached & tried several browsers and from phone.
I changed links from an anchor to a phone number and it works.
Hover over services and select any of the services from navigation and none of the anchors work.
All theme & plugins are up to date. Please advise.

Hi @6stringlove,

I have checked it in Chrome, Mozilla Firefox and my Andriod phone but didn’t find any issue related to the anchor links described. If you are still having this issue, I would request you to provide a video to recognize the problem.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.