After I upgraded X and Cornerstone my blogposts, will not display on Safari

I upgraded X from 7.2.3 to 8.0.11. and Cornerstone from 4.2.3 to 5.0.11 (as well as WordPress from 5.5.3 to 5.6, WPML from 4.4.6 to 4.4.8 and FileBird Lite from 4.2 to 4.3.1).

Now my front page, which contains the blogposts, will not display correctly on Safari (a slightly old version: Safari 10.1.2 / MacOS 10.10.5). The menu will display, but the posts does not appear.

It works perfectly on Chrome (MacOS/Windows/Android) and Firefox (MacOS).

The webpage is

Any idea on what is happening?

Thank you

Hello @asbjornflo,

Thanks for writing to us.

It might be the issue of plugin conflict or JS/CSS customization. I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing for Plugin Conflict
  2. CSS/JS Customization
  3. Version Compatibility
  4. Disabling Cache
  5. Child Theme

If none of those work, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


Hi @asbjornflo,

The credentials you provided is not working, please double check it. On the other hand, I suggest that you clear your browser cache in your Safari because the blog page is just working fine on Google Chrome and Firefox.

Hope that helps.

Thank you.

Hi @marc_a,

Sorry about the credentials, the right ones that I just tested are above in a secure note.

I tried to clear the browser cache in my Safari, but it did not work.

Thank you.

Hello @asbjornflo,

Thanks for writing in! I have checked your site on my Safari and it is loading as expected.

See the secure note.

Kindly clear the Safari browser cache or use private browsing mode and test your site again.

I tried clearing the Safari browser cache, using private browsing mode and clearing history as well. None of it works. Could it be because, as I wrote in the original post, that I use a slightly old version (Safari 10.1.2 / MacOS 10.10.5)?

Before I upgraded X from 7.2.3 to 8.0.11. and Cornerstone from 4.2.3 to 5.0.11 everything worked fine.

Thank you

Hello @asbjornflo,

It could also be because of your outdated Safari browser. Please have it updated to the latest version and check the site again.


Hello @ruenel,

Because I use MacOS 10.10 Safari 10.1.2 is the most recent version of Safari I can use. To upgrade Safari I need to upgrade MacOS. That is a bigger job, and it have to wait for now.
It is probably a good thing to know that X and Cornerstone does not work on some older versions of MacOS using Safari.

Thanks for helping out.

Hey @asbjornflo,

MacOS 10.10 Safari 10.1.2 is no longer supported but I’ll post this on our issue tracker maybe our development team might consider fixing this.


Hi @asbjornflo,

Regretfully we don’t support Safari 10 but we did have some regressions in IE11 uncovered that were because a polyfill for legacy browsers stopped getting included mistakenly. This has been fixed for the next release. I bring this up because it might actually fix the Safari 10 display problem as well. I don’t have a way to verify this so I’ve installed a development build on your site that includes those changes. You can safely update via automatic updates when the official release is available.

After updating your site I noticed that the portfolio items didn’t have padding like your screenshot. This is because we changed some styling for the next release and it conflicted with your custom CSS. In X there was an issue where the masonry wasn’t applying to search results of WooCommerce products becuase those don’t output the hentry class and we had to move some things around. I made a slight tweak to your custom CSS to move the padding from x-iso-container > .hentry to .x-iso-container-posts > .hentry .entry-wrap and it is working now on your site.

Take a look at your site on Safari and let us know if that did the trick. If not, could you open Safari’s developer tools and take a screenshot (like Christian’s) of any and all errors that pop up in the console tab when viewing on Safari. While we can’t officially support that version of Safari I wouldn’t mind taking one more look at it to see if there’s anything obvious that can be spotted. Thanks!

Now everything works perfectly as far as I can see, Thanks a lot!

You’re most welcome. It’s good to know that the site is working now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.