ACF Pro not adding paragraph tags

I’m using ACF Pro to add the content into these community pages: http://54.227.57.214/livemodern/community/miami/the-bristol-palm-beach/

I’ve tried the WYSIWYG editor as well as the Text Area with “Automatically add paragraphs” set in the New Line section. Neither of these are adding p tags in the content. I’ve tested with all plugins disabled and it still doesn’t work. Is there a conflict with the theme?

Help is appreciated.

Hi @marketfresh,

Thanks for reaching out.

To better help you with your concerns, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

I actually figured out the problem.

When I call in the acf content using this: {{dc:post:meta key=“community-content”}}
the paragraphs are ignored.

When I use this: {{dc:acf:field field=“community-content”}}
the paragraphs work.

Is this a bug or by design?

Hello @marketfresh,

It’s good to know that you have figured out a way to resolve the issue. One thing to note is that with the code: {{dc:post:meta key=“community-content”}}, the content output will be filtered thus removing the HTML code. The output of the {{dc:acf:field field=“community-content”}} on the other hand is unfiltered. Make sure that everything you insert especially with HTML codes in it, is valid and correct. Invalid codes will mess up the page layout or even create issues sooner or later and it would be difficult troubleshoot.

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.