500 Error when loading Child Theme Customizer

I have 3 copies of the X theme in use, but only one of them will not load the Theme Customizer:

www.dejoriacenter.com - 500 Error loading Customize.php
rhodesvalleyoutfitters.com - Work perfectly
stateroadtavern.com - Work perfectly

Nearly all the plugins used are the same and they all have a similar feel since they are all sister companies. The DeJoriaCenter.com site is the largest of the sites, but there is no reason this should be broken. All the sites are on the same independent VPS server used just for this batch of 4 sites (highstarranch.com uses a real estate theme)

I can’t figure out why this is broken. Can you give me some insight as to what to try so we can fix it? Here is what we have done:

  1. upgrade the Theme
  2. Increase memory to the php
  3. Tested plugins by turning off and on.

Nothing seems to allow the Customize program to work again… it was working perfectly when we built the site last year. Does anyone have any idea why this would occur randomly for the same theme?

Oh, one more thing… we lock down the www location of all these site for write access. So, the location this is built at is “dev.” instead of “www.”

Hi there @nvious,

Thanks for writing in!

It could be related to a conflict with another plugin/script running on the server, though it sounds like you’ve already tested for this. In which case it’s most likely related directly to the server configuration in a way or could be caused by Cloudflare.

As it’s an internal server error (500), can you check your server error log please as it should provide more information and hopefully will reveal a fatal error or similar.

Thank you!