X upgrade/Cornstone upgrade issue removes cornerstone edit

We updated our cornerstone and then the x and now we cannot edit in Cornerstone.

We tried some of the other suggestions but it didn’t help.

Please let us know what to to next.


Hi Dianne,

Thanks for writing in! I’m sorry to hear that you’re experiencing this issue. There are few things to check after updating your X theme and Cornerstone.

  1. Make sure that you have updated to the latest versions. As we have pushed updates time to time recently, you need to make sure that you have updated to the latest versions by referring to our changelog.

  2. If you’re using a caching plugin on your server, you need to purge your server cache. If you’re using a serverice like CloudFlare, you need to login to CloudFlare account and clear it’s cache. You need to clear style cache by head over to X -> Settings section. Also you need to clear browser cache before testing for changes.

If the above solutions did not help, then you need to install the following plugin (https://wordpress.org/plugins/wp-serverinfo/), head over to Dashboard -> WP-Serverinfo section and check the following configurations.

  • PHP version - We recommend PHP v5.6.x or later to avoid incompatibility issues.
  • PHP memory limit - We recommend PHP memory limit of 512MiB. If you see a value below, try following this guide on how to increase your memory limit.
  • PHP max script execution time - We recommend the value like 120 or higher like 300 for this setting. Follow this guide on how to increase it.

Also please check our troubleshooting guide here.

Let us know how it goes.

Purged the cache and still nothing. It’s just not showing up.
Any other thoughts?


Hi Dianne,

It could be something related to the new feature “permissions” added in recent updates, I recommend checking that there is no permissions issue is responsible for that by checking this guide:

If everything is okay, then please provide us with WordPress Dashboard login details in a “Secure Note” so we can investigate this issue.


Hi Dianne,

I had a similar problem. I updated X and Cornerstone quit working. I reinstalled Cornerstone manually.

Logged into C panel, then went to file manager, public_html, wp-content, plugins, Cornerstone.
My Cornerstone file was missing most of it’s files. So I downloaded X from Themeco and copied the new cornerstone file into the themes folder.

maybe not the best way, but it worked for me.

I hope it helps


Hi Seth,

Thanks for chiming in, that is actually re-installing Cornerstone, it would work. But as you already know that’s kind of tedious way, you can re-install Cornerstone easily, by navigating to the Plugins panel, deactivate and delete your current Cornerstone, then navigate to X > Validation, wait for a few seconds and X will automatically re-install a fresh and compatible version of Cornerstone for you.

If you have a follow-up question, we kindly ask that you create your own thread.

How to Get Support


sent you a secure note


I’ve tried everything and its cornerstone is not working .I’ve reached out for help and no one is answering this project is due tommrow for me and I have a client waiting this is unacceptable I need help on this issue and No one is helping.

you need to posts your own feed not on my feed.

I’m not getting any help so i’m posting everywhere. Did they make it work for you?

No not yet.

Hi @TweetyBird2005

As I mentioned before, insufficient permissions were assigned to Administrator in (X > Settings), I reset the permissions to default as in this screenshot:

Now you should be able to edit your pages with Cornerstone.

@snapmediadesign I’ll follow up your threads, knowing that keeping replying to your threads or other users’ threads push them down to the queue, hence they don’t get replied quickly.


Thanks! I think that worked. Do you know am I going to have this issue with all my sites? We own a lot of licenses.


Hi Dianne,

You shouldn’t, just follow this guide to update the theme to the latest stable version and you shouldn’t encounter any issue:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.