X Typekit isn't loading Brandon Grotesque properly

Something has happened with Typekit’s Brandon Grotesque. X theme is loading the font-family as “Brandon Grotesque”. The correct name is “Brandon-Grotesque”. Adding the hyphen in inspector corrects the font.

I’ve tried changing my heading font in customizer, then switching back to Brandon, but the incorrect name is still applied.

Hello There,

Thanks for posting in! This could be a bug in the parsing of font names in the theme. I’ve submitted this to our issue tracker so the developers will be made aware of it. Once they’ll have it fix, it will be updated and rolled out in the next update release.

Meanwhile, please deactivate the X Typekit plugin and use the Font Manager instead. Please go to X > Launch > Templates > Fonts and set up the typekit.

To know more about Font Manager, please check this out:

Please bear with us.

Unfortunately, the latest version of X theme isn’t compatible with WPML, so I can’t update the theme to get the Font manager.

Hi there,

Would you mind providing the URL to your site?

I have tried checking on the latest version of the theme and added Brandon Grotesque and I can’t see any issue when I assign it to an element.

Would you mind providing more information on how we could replicate the issue?

Thank you.

The site is truespecgolf.com. We’re currently running behind on Cornerstone (v1.3.3) and X Theme (v 4.6.4). We’ve held off on updating as we’ve been informed there are issues with WPML compatibility in the latest releases. The X-Typekit plguin is up to date (v 1.0.3).

As a workaround I’ve had to manually set the font family in our css.

Hi there,

It seems to be working on my end, the font that being applied is "brandon-grotesque" and it display the correct font. Perhaps it’s cache on your end? Would you mind providing a screenshot of what you’re getting?


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.