X Settings Background is not showing


I made a page design with cornerstone, saved it and published, then set as “Under Construction” page using the X extension. However, even if I just open the page, background doesn’t show up, unless I’m logged into WP (but it can be seen in the cornerstone editing page).

I set up a page background image with X Settings with fade and duration to 0, just to be sure.

If I open the page on other browsers, even on mobile I only see default background color and the content of the section.
If I open the page HTML from browser I can find the jQuery code and the HTML stuff that call the correct image URL. But in the jQuery function fade and duration are set to 0 e 7500. I dunno why.
If I open the image using the file URL I can see it properly.

All this even after clearing browser cache.

If I open up the folder via FTP in which the image file is stored, permission are set (automatically after uploaded on Media page) to 644.

If I set the background image on the body tag via CSS, it works properly.

Any idea? Thanks in advance.


PS: X is last release, as I downloaded and installed it just a few hours ago

Hi @snowtura,

Thank you for writing in, there is a big chance that is caused by a caching feature.

Please clear all your caching features (plugin, server-side, CDN, and browser’s cache). This will help you to avoid any potential errors.

If the issue persists, please provide us the site URL and login credentials in a secure note so we can take a closer look.


Thanks for your help.

Actually I do noticed I have some cache problems, so installed a cache management plugin, cleared cache and the new updates I made to the page went ok.

But I tried to set up the background again with X Settings and I had again only a default background color page with content and no background image.

But I really can’t empty cache every time I make a change in a page. :-/

Hello @snowtura,

The given username or password does not work for us. It seems it is invalid.
Can you please double check it?

Meanwhile, if you are using Ethos stack, you may need to add the following CSS code in the X > Theme Options > Global CSS (http://prntscr.com/evui3r)

body .site,
body .x-site {
    background-color: transparent;

Please let us know how it goes.

The Global CSS solution doesn’t seem to work, even after clearing cache again.

Now the usr and pwd should work :slight_smile:

Hi @snowtura,

Try adding this css.

body .backstretch {
    display: block;

Hope it helps.

Thanks @albrechtx.
It seems to work. Can I ask you to explain?

BTW, in the page x settings screen there’s no more background settings tab… :no_mouth:

Hey @snowtura,

The background image will be displayed as none by default. As soon as the page loads, the fade effect for the background image will trigger to display the image. The custom css overrides the fade effect.

The Page X Settings is present. You can only add a duration and delay.

Hope this helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.