Wpbakery and acf


Before contacting themeco cupport, I’ve tested to insert an acf using wpbakery issue on another website and it worked fine.
However, within this theme happens the following issue:

  • When inserting an advanced custom field to a post type using wpbakery, the layout shows a gear wheel instead of the acf logo, thus when loading the post type it simply returns an empty screen;
  • I disabled all the other plugins to check for a conflict and still happening the same error.
    As both acf and wpbakery are built-in I can’t contact them to ask for support.
    DO you have an idea or Is it possible to check what may be causing the error?

Hello There,

Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. If you’re using a CDN(ex: CloudFlare), please clear the CDN’s cache and disable optimization services. For the CloudFlare you also need to follow the steps below besides the developer mode: https://xthemetips.com/using-cloudflare-rocket-loader-with-x-pro-and-x5/928/1
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Switch to the parent theme to check if the issue persists.
  7. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  8. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Thank you for your reply.
I’ll follow your suggestion and check the steps one by one.
Hope to find the problem.



Steps checked:
1- Visual Composer version 554 (automatic updated not available to 555 as it is built-in)
2- Done
3- Not using
4- Done
5- None used so far
6- Done
7- Done
8- Done

Everything checked.
The website where I’ve checked first the integration of ACF in VC is in the same server.

So, if you kindly take a look:

  • to check the issue you may use the CPT “publicacoes” and when adding a new post you’ll find two ACFs “autor1” and “autor2”.

Credentials in the secure note.


Hello @Amoeba,

Nothing is displayed because you haven’t added the code in your publication template file.

<p><?php the_field('autor_1'); ?></p>

If you are using Pro Editor, you can simply add {{acf:autor_1}} in one of the text elements and it should display the custom field.

Please check out our knowledge base article to know how you can display the field: https://theme.co/apex/forum/t/integrated-plugins-acf-pro/49

By the way, Pro 2.3.6 is now available in automatic updates! This release contains fixes for several issues so be sure to check out the changelog (https://theme.co/changelog/). Please do update to the latest version. After doing the updates, always remember to clear all caches when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Please let us know how it goes.

Sorry to insist. As I said in my first message, the acf fields have been always displayed in the custom post page editor (publicacoes). That wasn’t never the problem. It seems that my first message was lost.
The problem is with the wpbakery that when using the acf element it isn’t able to retrieve the value inserted in the acf box bellow.
Please see the attached image.from my other website without adding any code
and now the attached image from this website . You may see the difference on the acf logo.
Further, the output doesn’t show any wpbakery elements such as a text block when the acf element is inserted in the layout. See both images

and as you can see

Without using the acf element, all the other wpbakery elements appears in the page output.
Definitely there must be an error occurring.

My goal is to create a library and use wpbakery to create several templates to set the contents layout according to the type of publication.
I’m not using the pro editor for layout templates because I’m used to wpbakery for a long time.

Nevertheless, I added the suggested code to wp-publicacoes.php and the issue still persists.

Please, check the problem again and be more concrete before asking to test any solution that might not solve the issue.

Many thanks.

Hey Rogerio,

Regretfully, I currently could not find the cause of the issue in your site. I’ve enabled Legacy X Integration option in WPBakery Page Builder Settings > General in your site as recommended according to our latest Release Notes but the issue persists.

I have tested ACF and Visual Composer in my test site and I don’t have any issues though. I tested a Link field in the Page post type and outputted using the ACF Visual Composer element and it displayed in the front-end successfully.

I’m afraid to investigate deeper in your live site though as it might break so would you mind creating another ACF field and test if it will display in the page post type? If that is successful, there might be some setting in your post type that causes this.

I’d also recommend that you copy your site to a staging server so we could freely investigate without the risk of breaking your live site or interrupting the operation.


there is no way to show the acf using wpbakery. I reinstalled the plugins with no results. Created a new acf and assignen it to default post type and also not working.
With the new version, the wpbakery also shows pro elements. In such cases the elements that insert code also don’t work inside wpbakery. Therefore I can’t use custom fields even using alternatives.
Any idea?

There might be something in your server and/or WordPress setup that is causing this issue. Would you mind testing copying your site to another host and also test a fresh WordPress install with only Pro, Visual Composer and ACF?


I installed the wordpress in a subdirectory archtech.pt/themecopro/ with a new database and just activate the theme, the wpbakery and the acf pro. Still not working. Same for coding elements of pro.
As I mentioned before my other website is in the same server as this one and it’s working there.

You may check it using the credentials.

I’ve changed to this theme but i’m starting to regret to have done it. Considering asking for a refund and searching for another theme.


Thanks for creating a staging site. Upon checking, ACF is working. Please see the screenshots below:

Would you mind giving the specific details why you said it does not work in your staging site also?


i checked and it’s really working, I was confused by the gear wheel. Menwhile, the wpbakery support told me that your theme is replacing the acf logo by the gear wheel.

Probably the issue was caused by a database conflict as I tested CPT UI/ACF and Pods.

So, would you advise to clean the database on the main site and restart to install the website?
So far, my only great concern is the header and footer. Is there a way to save them and upload them later?

Many thanks and sorry for any inconvenience.

Hello Rogerio,

Thanks for updating the thread.

You can save the header and footer as template. After that you can download the same and import again at later time. To help you get started, please take a look at following screencast.

To learn more, please take a look at following article.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.