Woocommerce Cart Not Updating Properly

Recently my site flowdna.co.za has stopped updating the cart after the first cart update is created.

Example; a customer (logged in or not) adds a product to cart, this works. From here on no other changes to cart happen, the customer can’t add more products, change quantity/delete in the basket, the cart does not change unless the customer deletes history and cache, which empties the cart and then the problem continues after the first addition to the cart.

I’ve tried disabling all plugins except woo commerce, still no difference. Theme, wordpress installation and plugins have all been updated to the latest versions.

Hey there,

I see the issue. Please check for the following first:

  1. If you’re using caching and optimization plugins, please clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.

  2. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

  3. Remove custom CSS, Javascript and templates.

If those don’t work, please copy your site to a staging server and give us WP Admin and FTP access in a Secure Note. If you allow us to investigate in your live site, the staging process is not needed. However, troubleshooting could potentially break your site and remove live features you have.


The cart was updating for a short while. But now it’s back to the same problem again.
The site can’t change/update shipping details
And on “place order” in check out the page returns - SyntaxError: Unexpected token < in JSON at position 0. - if you submit the order and wp_debug is true.

The customizer can’t save and publish when I try remove custom css. Even with all plugins disabled.

WP admin and ftp access is in the secure note

Hi there,

I did check both front and end and added some sample in the cart and I don’t see any issue. I can’t even find there the JSON error. Perhaps it’s in your end only? Have you tried other machine?

And please provide a video recording, maybe what I’m doing is just different.


Here is a link to a video of me reproducing the problems.

As you will see, after the first item has been added to cart, nothing can change afterwards (unless the user clears history).
The item can’t change quantity or be deleted from the basket.
In checkout page - shipping method cannot be changed/selected(this also happens in the basket page) and submitting an order returns an error.

The JSON error is returned when wp debug is set to true in the wp-config.php file. It is currently set to false.

Can’t access your server. Please check but before that, please completely remove W3 Total Cache from your system then check if the issue persists. See https://www.shoutmeloud.com/how-to-delete-uninstall-w3-total-cache-wordpress-plugin.html


W3 Total Cache has been removed.
I can access my server. Possibly try again?

Hi There,

I am able to check though I can’t duplicate the issue you were having. The cart updates as expected. See this: https://screencast-o-matic.com/watch/cbjXe8lmo5

Then I tried to delete from the cart: https://screencast-o-matic.com/watch/cbjXeRlmoN

For checkout, I can see the issue though there’s no error at all. Can you double check your shipping settings? See this: https://docs.woocommerce.com/document/setting-up-shipping-zones/

That’s very strange, why would the issue persist for myself and the customers (we are still getting complaints)?

I’ve tried clearing all browser history, cache, saved data, etc. on chrome, firefox, safari and I still get this issue.

Hi there,

I can confirm the issue in my end at least now, and it looks like an internal issue. The cart process is handled alone by Woocommerce, and it’s done internally through PHP. Something is failing in random occasion, have you tried contacting a developer?

Plus, if you can provide your correct FTP login credentials then maybe I could gather some information (error logs) that you can forward to your developers.


Managed to fix the issue myself.

It wasn’t from the theme that the was causing the problem, seemed to be a woo commerce error that I managed to fix. But you guys helped me out regardless and I really appreciate that.

Thanks a load. Point me in the reviews direction and I’ll happily make a good one.

Glad it’s okay now and you’re most welcome :slight_smile:

Hello Lyle,

Im having the same issue. How did you fix it?


Hi Kelly,

Please check error logs first. See if there’s any error from woocommerce. We can start troubleshooting from that information.


I am having the same issue. Which log should I be checking please?

Hi @l3kilos,

Please let us know details about your issue. Also post the error log you’re getting from Woocommerce.



The error is only happening in some browsers. it works fine on Chrome, but doesn’t seem to be working on Miscorsoft Edge, and possibly Safari and Firefox.

The issue is that once the cart has been updated once, subsequent attempts to add/remove products are unsuccessful. Some customers are also reporting that they can’t update the cart at all even the first time around trying to add a product, although it says that the product was added. But when you go to the cart it’s empty. I could not reproduce that issue myself, however i can reproduce the updating issue.

The php_error log only contains the following error:

The WC_Coupon::exclude_sale_items function is deprecated since version 3.0. Replace with WC_Coupon::get_exclude_sale_items

Hey @l3kilos,

Would you mind giving us information about your setup?

  1. What version of X and WooCommerce are you using? Can you try downgrading WooCommerce to an earlier version?
  2. Do you have WooCommerce customizations? Can you remove all customizations for troubleshooting?
    3 .Did you try the suggested solutions earlier?

If you’ve done that and nothing helps, please open a separate thread and give us WordPress admin and FTP in a Secure Note there. Also post a link to this thread for reference.


There wasn’t really a solution posted in this thread. The person who originally posted it indicated that they managed to fix the issue themselves but did not say how. I will open a new thread and provide the necessary information. Thanks.

Yes please open a new ticket and we’ll continue there.