With SSL activated I only see header & footer content


We just launched our new website and when I activate the SSL certificate and use the Velvet plugin to update all links & switch to https in the general URL settigs, all I see are the header and footer. There is no content on most pages (there are some photos shown on some pages). When I enter the Cornerstone customizer I see no content as well.

What did I do wrong to get this problem? I went back to HTTP untill I know how to solve this. Hope someone can help me :slight_smile: Cheers!

Hello There,

Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. If you’re using a CDN(ex: CloudFlare), please clear the CDN’s cache and disable optimization services. For the CloudFlare you also need to follow the steps below besides the developer mode: https://xthemetips.com/using-cloudflare-rocket-loader-with-x-pro-and-x5/928/1
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Switch to the parent theme to check if the issue persists.
  7. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  8. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Thanks for the reply! :slight_smile: I tries everything several times and I can’t get it to work. Hopefully you can take a quick look.

Hi @peevdtee,

It doesn’t seem to be SSL related, it could be due to performance issue. It won’t load or display the preview, but after few retries, it does work but slow. Have you tried increasing the memory limit?

Or does this happens on a specific page? Please provide which page has this issue.



Thanks for checking. I already dit the ‘define(‘WP_MEMORY_LIMIT’, ‘512M’);’ in WP-config. It happens on all of the 5 pages on the website :frowning:


Hi @peevdtee,

I just tried it again and it loads almost instant now, may I know which browser and device you’re testing it with?

Please check the video recording in the secure note, it loads almost 10 seconds (from the time the loading icon appears).



Note that it’s now still in the ‘HTTP’ mode, link-wise. I moved all the links back from HTTPS to HTTPs. In ‘HTTPS mode’ the errors apear, while in ‘HTTP mode’ there is nothing wrong. When I change all the URL’s to HTTPS with the Velvet Blues Update URLs plugin, the error apears on all the pages. You can test it out if you want.

The SSL certificate is still active though, that’s why you get the ‘i icon’ in the URL bar. I’m using Chrome on a Macbook Pro by the way.

Hi @peevdtee,

Do you mean that what I checked is HTTP configuration? In that case, I missed the issue and the only way for me to see it is setting it back to HTTPS, and maybe the issue is the redirect. Could you try setting it back to HTTPS and let me know :slight_smile:


Done :slight_smile: Now you can see only the slider is working on the homepage, the slider on the 2nd page and the Google Maps map on the contact page. Everything else is gone (besides the header and footer, they are still there)

Hello @peevdtee,

Thanks for updating in! I have logged in and check all your pages. It seems that all of the pages were edited outside of Cornerstone. Please keep in mind that you cannot switch between editors. Doing so will corrupt the cornerstone data and may no longer be editable in Cornerstone.

If you have created a page in Cornerstone and have switch to text mode, copied the codes and pasted on a new page, this method will not work because none of the cornerstone data will be copied. You must save the page as a template and import it to the new page.

For more details on how you can work with templates, please see “Working with Templates” section in this page: https://theme.co/apex/forum/t/cornerstone-content-builder-layout/122

And for more details about the Template Manager, please check this out: https://theme.co/apex/forum/t/template-manager/20364

Hope this helps.


I only used the Cornerstone editor, not the text editor. That’s one of the strange things that occurs when you change from HTTP and HTTPS.

Ho @peevdtee,

How about we do it in staging? I’m afraid doing the troubleshooting could damage it further (since it’s more related to data). You could use All in one migration plugin to create a clone of your site, simple export your site as a file using that plugin and import it to the another Wordpress installation (sub folder or sub domain).


Is it an idea to send you the .ZIP and installer.php file via Dropbox so you can test it on a system of your own?

Hi @peevdtee,

No, that would not work for your server may have a different configuration from ours and we don’t have your SSL certificate for the URL.

The fact that you manually change the URL on Settings > General and the Mix Content Warnings (see screenshot below) that your site is throwing, this means your plugin failed to change all the URL from http to https entry on the database and that causing the Cornerstone not to work properly.

Try to use the Better Search Replace plugin instead, follow the advice provided here.

Remember to clear all your caching features (plugin, server-side, CDN, and browser’s cache) after updating so the changes will take effect immediately.

Let us know how it goes,

Yes! That plugin did the trick. Man, I spend several hours to solve this. Many, many thanks guys <3

Glad to hear it’s sorted. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.