When I save headers, all bars disappear


This is a new problem. We are trying to edit headers and footers in Pro 2.2.5, but when we hit save, all of the bars are gone. It makes the entire header or footer completely blank.

I created a new header from one of the templates, and that did not get wiped out on an edit, just the ones I created previously, and of course the ones that are live on the site.

Any idea what could be causing such an odd issue?

Hi There,

Thank you for writing in, there might be a broken HTML tag somewhere on your header content. Please audit all your header content, make sure there is no <div>, or <p> or any HTML tag that is not close or broken.

You can use this tool here.

If you can’t find any broken HTML tag, please provide us login credentials in a secure note so we can take a closer look.


Thanks for the reply. Is it possible to see all of the code for the header/footer elements somehow without going to each item one by one? I looked at the page source and didn’t see anything too crazy.

Also, since it does this on the footer as well, I’m not sure this is the issue.

I’m really sorry this happened. We didn’t encounter anything like this in beta testing. It does appear that the bar data is in fact gone which makes me wonder how it got corrupted and way it would no longer show up.

  1. Are there any old headers or footers that are still intact? Would you be able to provide access to the database and/or FTP? I would like to do some more testing but want to be very careful not to delete anything else and this would help me make adequate backups.
  2. Do you have a full backup of the site anywhere? If so I could get me one I could go in and find a way to restore the header that was lost. I might also be able to do more intense testing safely in a local environment.


  1. I deleted all other old headers and footers. I’ll leave a secure message with cpanel login details. There are backup and restore controls there, and FTP login is the same.

  2. I took a backup this morning. Restoring the bmzchurc_wp2018 database alone brings it back. I did so now.

One thing to note: The site is running on PHP 5.6 since their current site can’t support 7.x, but we plan to upgrade to 7.2 once we launch this weekend if you think that may help.


So glad you were able to restore a backup! I’ve checked the database and what’s happening is that it saves about 60% of the data and stops which makes the whole thing unreadable. So it is in fact being corrupted somehow.

I enabled WP_DEBUG so you might see PHP warnings while I continue to check on this. I’ll update you when I know more.

Hey Matt! So I believe this might be a resource utilization problem or a plugin conflict. A quick way to test if it works without breaking anything is to duplicate the header, then see if the duplicate loads with bars or not.

I tried this after deactivating all the plugins and it works correctly. I was expecting to get some kind of PHP error but nothing came up. You could try updating to PHP 7 and seeing if that gives your system enough resources to fully duplicate the item. Or you could try testing for a plugin conflict. You can do this by deactivating the plugins one at a time and testing it. Once it starts working we may know which plugin is at fault.

Ok, so probably a plugin conflict then, we’re thinking?

I updated to PHP 7.2 and tried to edit the copied header, but it broke. I’ll have to test the plugins later this evening.

Is there any way to force more resource allocation considering this is on shared hosting, or do I need to contact the provider? This site was recently moved to this new server and we were told it would have a lot more resources than the previous one.

Hi @dmdstar,

Please try downgrading it below 7.2, 5.6 to 7.1 should be fine. I’m not saying the Pro theme isn’t working with 7.2, but if there are other plugins and custom code affected by that version due to some deprecated functions, then the builder could be affected too.

The allocation is imposed by host environment and it can’t be overridden by Wordpress itself, hence, it’s best to contact the host to see if it’s possible. Another problem with shared hosting is, even if your site is optimized and faster with fewer traffic, it could still be affected by other heavy sites sharing the same resources (hence, shared hosting).


Update: This turned out to be a plugin conflict as expected. I discovered a single plugin which adds links to bible verses automatically, that when enabled caused this behavior. No idea why this conflicted, but that was the culprit.

Glad to hear that the problem is resolved now. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.