Hello there.

I am unable to validate my license in wordpress - I keep getting this error message - Uh oh, we couldn't check if this license was valid.

I have read through some support forums and have tried revoking my license and trying again but I'm still not getting any further.

Please could you assist?
Thank you

Hi there,

This seems to be a CURL connection problem between your server and ours. Kindly contact your hosting service provider and ask them to follow the steps below:

Thank you.

Hi, thank you for getting back in touch. I have contacted BlueHost, using the form in the article you have provided, but they have requested I get back in touch with you as they have checked the following
• Ensure my site can reach this domain:
• Ensure cURL is working, and allow_url_fopen is enabled.
• Ensure PHP is configured with the latest CA Root Certificates.

and they say the site is working fine and it seems to be a problem with the theme provider?


Hey There,

Thanks for updating in! I went ahead and investigated further. I have increased the time out limit and validated your site. I am using a test license by the way. I was successful in validating your site. You can check out my screenshot: and your site in X > Overview page as well.

Since this is just a test license, you will have to revoke the license and re validate the site using your own license. To do that, please do the following:
1] Please go to X Addons > Overview and revoke the validation (
2] Please login to your account and revoke the license.
3] After you have revoke the license, you need to re assign the license again to your site using this url: You have to make sure that url you just assign is the same as the one you have in your settings, Settings > General > Site Address
4] Go back to X Addons > Overview again, and insert your license code.

And please review the changes that we made on how you are going to validated your X theme because we made a big change in the process. Please check it out here:

Please let us know how it goes.

Great - Thanks for that. I have revoked it and validated it using my code and it has worked. I really appreciate your help with this

Thanks again

Glad to hear we managed to help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.