Validation problem after update

Hi Support
I just managed to update to the latest version of X from a VERY old version. However I had a bit confusion upon validation. First I got the message that the API code was valid but seemed to be in use by another site - the thing is that I have a primary domain and a subdomain - the site is the same but it can be accessed from both URL’s. After unlocking the license from my account and editing the site (production) from to I got a message in the WP Dashboard that my site had been validated. However, I am notified that Cornerstone still needs to be validated.

I have then changed back to and also changed the url in the wp setting from to - perhaps I have now made a complete mess of things. My aim is to build a completely new site only known as I cross my fingers that you can help me to sort things out.

Best from Signe

Hi Signe,

Thanks for writing in! You don’t have to validate Cornerstone plugin at any point. If you’re getting that screen, it means either your X theme / Cornerstone plugin is corrupted or you’re using older/incompatible versions of X theme and Cornerstone plugins.

First check our version information here ( and make sure that you’re fully updated. If you’re using older version of X theme or Cornerstone plugin, you need to update them as well ( We also have troubleshooting guide here (

If you’re still having issues, provide us with your WordPress login credentials in a secure note to check your issue further.


HI Signe,

Thanks for the details but did you happen to change the login link for your site? I tried checking /wp-admin and /wp-login.php but I am getting this:

Would you mind providing the URL of the login page? For the meantime, please double check the version of your X and Cornerstone make sure that they are both updated.

Hope this helps.

Hi Jade

I am not sure if I am replying in secure note - but I think you should be able to access now. The url is

I just updated yesterday to the newest version of X so everything should be up to date :slight_smile:

Best from Signe

Hi There @sasinsine

I have re-installed your Cornerstone plugin, but your issue remains. That means, most probably your X theme is corrupted. Could you please try re-installing the latest version of X theme and see if that resolves your issue.

You can switch to a default WordPress theme, then delete your X theme, download the latest version of X theme from your Enavato account and re-install it trough Appearance -> Themes area. All of your current settings and data will be saved in the database, so that you can safely delete and re-install X theme.

Let us know how it goes.

Ok I’ll try right away - although that was exactly how I did it yesterday. But I am hopefully crossing my fingers that it will work better this time :slight_smile:

Ok so I just tried re-installing and got the same message as yesterday when trying to re-install the downloaded zip file through Apperance - Themes area: The link you have followed has run out - try again ??

How can this be? I have just downloaded the file from the download button in my dashboard frontpage here in APEX?

Yesterday my solution was to upload via ftp after several attempts at installing wordpress theme area…but apparantly that was not a good solution…

Best from Signe

Hi again @mldarshana. Downloading the file directly from Themeforest/Enavato account and then trying to upload in wordpress didn’t work either. Got the same message again that the link has expired!!! Uhhh, I am getting a bit desperate now… :sweat:

BTW: I noticed that 2 other members had similar problems in the past 10 days (unable to re-install theme/file expired message and troubles with validating). In both cases no easy fix it seems from the support tread. I really hope you can help me out on this - since I have been unable to work on the site for 2 full days now. Thank you :slight_smile:

Hi Sasinsine,

I have investigated this and found and resolve the issue, the main issue here is you seem deleted the X theme? So if we could re-install the X Theme your Cornerstone validation issue will be gone.

Now I tried to install the X manually via Themes > Upload and as you know that did not succeed because of the The link you followed has expired. error.

Upon investigation on that error, I found that issue is caused by this:

Yes, your site’s max upload file size is only 10MB, where the X zip file is 10.6MB, I installed a plugin named WP-ServerInfo to confirm that and found your server specs is pretty low (see Dashboard > WP-ServerInfo).

Nevertheless, I tried to increase the max upload file size so I can upload the X. I tried all the tricks provided here, but none works, this means your hosting/plan is not allowing you to increase these things manually.

I have no choice but to upload the x folder via FTP, and that seems to work.

Don’t worry about the Slider Revolution asking for validation, since the Revolution Slider you have is a bundle with the X, you don’t need to validate it. that will function 100% without license registration.

Your concern now should be these:

Please contact your hosting support on how you can effectively increase these stuff, more importantly the Memory Limit.

Hope it helps,

Hi @friech. Thank you SO much for solving the problem - and also for your very thorough feed back on the cause of the problem. You made my day :slight_smile: I will contact my host and get the memory limit solved.

Best from Signe

On behalf of my colleague, you’re welcome. Cheers! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.