Upgrade Issue with header customized style


After upgrade to Pro v.2.3.6, my customized header (option 3 header style) gone nowhere. see this this screenshot for my previous header:

But now see here: https://activerify.com/

It seems like that header page is automatically removed.

How can i get it back?

Please help ASAP.
Thank you,

Hi Sovann,

Thanks for writing in! You are experiencing a caching issue. After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Please let us know how it goes.

Already cleared the cache, but still there is not that home page. It’s gone.

Let me elaborate a bit about the issue as below:

Today i accessed my site, i saw the update, then clicked update.
I then changed my site logo as the previous png logo is too big, then changed to a small size to speed up the homepage load. When clicked on header, keep loading but saying something like " (The preview was unresponsive after loading. This is most often related to a plugin conflict or aggressive page cacheing.") I then tried to refresh that page, i then saw the two headers that i had, top header (menu header) and bottom header (option 3 style)
After that i tried to click on the option 3 style header, but i could not see the header and the footer. I then refreshed the page again. At the same time i tried to access the header via “Customize”, i then accessed the header from there.

Finally, i didn’t see the option 3 style header anymore.

Please,… how can i get it back.

Thank you,

Hi @sovann,

I just checked and the header loads just fine without issues on my end. BUT, I do see that scripts has DEFER attribute, plus, there is a code that loads a different copy of jQuery.

<script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js' defer='defer'></script>
<script type='text/javascript'>try{jQuery.noConflict();}catch(e){};</script>

Could you try removing all optimization of your site including the one that adds that jQuery library? I recommend using the jQuery version built-in to Wordpress. If this isn’t possible, then I recommend cloning your site into staging. You can have staging to your sub-folder or sub-domain and if your hosting provider has a staging feature, then you may check their documentation on how to set it up. Else, try using All in one migration plugin to export your site as a file, then import that file into your staging (another clean wordpress installation) using the same plugin. That way, we can check the issue without any optimization and troubleshoot it without harming the actual site.


Sorry, I’m not a web developer, i do not really understand what you mean.

I did redo it again. However now i’m struggling to assign two headers to show at home page or any other page while i could to it before. See screenshot for more info

Please help ASAP.

Thank you,

Hi Sovann,

I am not sure if I am following you correctly. You can not have separate headers added to one page. The header builder itself has the Bars that you can add multiple bars which will work as separate headers. But you can not assign 2 different headers to 1 page. That is not related to the current update but the Pro Header Builder was always that way.

I did check the case with an old version of the Pro and did get the same warning message:

So, bottom line, you can add 1 header to each page. But that 1 header can have multiple bars. For more information:

Thank you.

Thank you for your elaboration.

The problem is fixed.

Thank you very much for your extensive support.

You’re welcome. Glad we’re able to help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.