Updated Cornerstone. Now it won't load

I just updated Cornerstone and now it won’t load when I click ‘Edit with Cornerstone.’ The icon just spins and spins. Any ideas? I’m kind of sorry I updated it now.

Hello @debbiepacker,

Thanks for asking and apologies that Cornerstone is not loading on your setup post update.

Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  7. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

I have the same problem. I can’t load any pages in cornerstone, just get the pounding cornerstone symbol forever.
Sucks that I have to spend all of this time and effort trying to diagnose and fix a problem that didn’t exist prior to the update. Is it likely there will be another update soon? If there is maybe I can save myself a few hours work and just wait for the update?

Deactivating all plugins and test each individually = problem with W3 Total Cache
So W3 Total Cache is now deactivated what is next step?

Hi @artisticdog,

For now, you could disable W3 Total Cache plugin while developing your site. If you are not developing, you could enable it again so that it could help you optimize your setup.

If still there is problem, please open a new thread and share us your admin credentials so we could check your setup closer.

Don’t forget to set it in a secure note.


Hello. Thank you for the reply.

We went through this list, and we are still having the same issue. This started when I did the Cornerstone update yesterday.

Reading through the forum, I noticed that there are several other people who are having the same issue since the update.

Hi There @debbiepacker

To further narrow down your issue, please install the following plugin (https://wordpress.org/plugins/wp-serverinfo/) activate it and then head over to Dashboard -> WP-Serverinfo section.

Then check the following server configurations.

PHP Version - We recommend PHP v5.6.x or higher to avoid incompatibility issues. If you see a version below 5.6, you can contact your hosting provider and ask them to update it.

PHP Memory Limit - On the first reply, @Prasant mentioned on how to increase memory limit. If you have done it correctly, you should see your current memory limit as 512MiB. Some hosting providers does not allow to change these values. In that case, you will need to contact your hosting provider.

PHP max script execution time - We recommend the value of 120 or higher (300). Here’s how to increase that value (https://www.simplified.guide/php/increase-max-execution-time).

Usually that should resolve your issue. if you’re still experiencing the same issue, please provide us with your WordPress login credentials in a secure note to check your issue further.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.