Under construction seems not to be working

Hi guys,

I activated, deactivated, uninstalled, re-installed the under construction plugin. Cleared all browser caches and the website still shows without

What can be wrong?

Cheers Carlo

Hey Carlo,

I see the under-construction page does not work in your home page only. There could be something in your WordPress and /or server configuration that is causing this especially related to cookies and white-listed IPs.

If you have a third party plugin related to cookies and white-listing IPs, please deactivate them temporarily and check if the issue persists. If it does, please give WordPress Admin and FTP access in a Secure Note


Thanks Christian

I can’t find anything… what email to use for the account?

Hi @quinex,

You can use any email or just provide your existing admin account and FTP in the secure note :slight_smile:

For the meantime, please go to Admin > Pro > Under Construction and make sure it’s enabled.


It is active and just shared the credentials in a secured note


Hi @quinex,

It looks like your hosting has internal caching (object, memcache, or database caching I’m not just sure which one), I recommend turning that off for now, or contacting your hosting provider about this. Try accessing the URL I provided in a secure note, the under construction works.


Awesome, I haven’t thought of that…

Just checked and in the server setup for the whole server I noticed varnish and memchached are enabled and for this particular domain is had varnished enabled. Disabling it made it work perfectly well.

May I ask one additional question?

What is recommended:

  1. Server caching and then either varnish, memchached or both
  2. None of the above and use a plugin like w3tc, wp fastest cache, w3 super cache
  3. A combination

Or can you not answer this question? It’s just out of interest.

Thanks for the great service!!!

Most caching plugins utilize varnish or other caching system of a web host when available. You will need to contact the caching plugin support for this though.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.