Unable to validate PRO license

I switched hosts and had to re-install my website and the X-Theme on a new server. However, i am not able to get my PRO license validated when i go to X > Validation. When I enter my license key, i get a grey box and nothing happens.I tried this several times.

I have added my domain name next to my license in the Apex portal as well.

I tried another unused X license I have, which also did not validate.

Any help would be appreciated,
Thank you.

Hi @ICD,

Thank you for writing in, please do the following:

  • Ensure that you are fully up to date. WordPress, Theme, and Cornerstone (Version Compatibility)
  • Clear all the site caches (plugin, server-side, CDN, and browser’s cache) so that the code from the latest release is always in use. This will help you to avoid any potential errors. Please deactivate this caching features while we tackle this issue.

If the issue persists, please provide us login credentials in a secure note, so we can take a closer look.


I checked the versions and have
WordPress V 5.1.1
and had just downloaded X-Theme Pro version 2.5.5

I cleared all the cache i had access to: browser and cache plugin. I don’t have access to any server cache settings.

Hi @ICD,

I can confirm the issue. Tried it and found it was related to curl setup of your hosting. Please contact your hosting provider about this settings. See this guide: https://theme.co/apex/forum/t/troubleshooting-validation-connection-issues/201. Under contact your host, please see sample email.

Hope this helps.

Hi I’m having the same issue

How do I send you my site credentials? I can’t see anywhere to make my reply private…

Hey @ArmshouseGroup,

I have removed your login credentials here because the original poster could see it. Please open a separate thread if our previous suggestions here didn’t work for you. Submit your credentials again in the new thread.

Please also review our How to Get Support article to see how you can efficiently use our support service and also what’s not allowed.


Thank you for your help, I was able to resolve the issue. It was a server side firewall setting that blocked the validation. Once turned off, it magically worked :slight_smile:

Hi @ICD,

Glad you sorted things out and thank you for sharing the solution.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.