Unable to install any extention after validation of page


I’m new to Themco and have just installed the X theme on a fresh website, with only a few other plugins at present.

I’ve just finished the validation process and was looking to install some extensions, but unfortunately am unable to do so. I searched in the knowledge base and the forum, and read through a few posts/articles, but that didn’t help me.

I’m running the newest edition of Wordpress (5.2.2–da_DK), have everything updated and have literally just finished installing the x theme. I have almost nothing else installed, apart from the Lifter LMS plugin, Contact form 7, User Role Editor and Wordfence Security. When I installed the theme, Cornerstone was also installed.

I’ve increased my PHP-memory through the wp-config file following the advice from one of your articles, though to no avail.

The Error that I receive is that regardless of which extension I try to install, nothing happens when I click on them from the validation page. And if I enter the bulk extension manager and click on install on any extension, I get the error:

Download mislykkedes [Danish for: “Download failed”]. cURL error 28: connect() timed out!

Please help as I am setting up a new page and would like to build it up using almost entirely X and related extensions.


Hi Imran,

Thank you for the detailed information on the steps you have done so far. The issue is probably that curl error. You might need to contact your hosting provider about CURL connection. Please check this guide..

If the issue occurs even after curl is settled, please share site URL and credentials inside a secure note so we can investigate further.

Hello Lely

Thanks for your response. I’ve written a message to my host and hope to hear back from them soon.

If nothing helps, I will do as you suggested and get back to you.

Thank you


You’re always welcome Imran!


Hello again Lely

Unfortunately, the problem wasn’t resolved. My host responded that allow_url_fopen is already enabled on the server.

What sort of credentials would you need to take a look at the site?


Hi Imran,

Wordpress URL and admin credentials please. Please remember to add it inside a secure note.

Hello Lely

I was away for a few days, but just tried it again and it works now. I don’t know what happened, maybe it was just a glitch of some sort.

Thanks for the quick and excellent support.

Best regards

Hey Imran,

It’s good to know that your issue has been resolved already.
Please don’t hesitate to open another thread if you need anything else we can help you with.

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.