Unable to edit X theme!

I am attempting to edit some pages in my copy of x Theme. I used WP bakery to create the pages. No longer there and I have updated all plugins.

Hello Vincent,

Thanks for asking. :slight_smile:

Please try out following solutions and see if you are able to edit pages:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  7. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

I tried all your recommendations, unfortunately to no avail.

Thank you for your assistance.



Hi Vincent,

It seems that you have forgotten to post the username. Please update the WP credentials so that we can login and investigate your issue.

To know how to create a secure note, please check this out: https://theme.co/apex/forum/t/how-to-get-support/288

Thank you in advance.

We will be responding your other ticket shortly.

Hello Vincent,

Thanks for updating the thread.

Can you please confirm the login details again as I am unable to login with shared credentials and getting error message (please see secure note)?


Hi Guys,

Sorry for the confusion. I have updated my password, the following is the correct login credentials;

Thank you,


Hi Vincnet,

You have shared your credentials publicly, but I have moved it into a secure note. I suggest you to change the password immediately.

In the meantime, I have checked your site and see that you’re still not fully updated. You need to update X theme, Cornerstone plugin as well to the latest version as we have fixed some bugs which you can see more information from here (https://theme.co/changelog/).

Let us know how it goes.

Hi Mldarshana,

Thank you for securing my login information. I have changed my password, which I shared with you via the secure inline reply. I still have the same issue, unable to edit using wpbakery.

All the best,


Hey Vincent,

Thanks for the updated credentials. I’ve logged in successfully, went to the WordPress editor and I saw the Visual Composer interface was not loaded. I then fired up the console to see what errors are generated and I saw a JS error.

The JS error is coming or at least related to the WordPress core and not from X. The usual cause of that is corruption during WordPress core update or just updates in general.

Please try reinstalling WordPress by going to Dashboard > Updates and click the Re-install Now button.

If that does not work, we’d like to double check on the troubleshooting steps @Prasant provided. I’d recommend that you setup a staging site though and copy your live site to it and give us staging WordPress Admin and FTP access. The main benefit of doing that is we can troubleshoot without disrupting the operation of your live site. If you’re not familiar with setting up a staging site, please visit the guide below:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.