Uh oh! Failed to Save Content


I am having an issue saving a page after making edits. This issue only occurs on one specific page (https://www.ngorganize.com/impact-news-and-events/). No matter what edits I make I get the ‘Uh oh! Content failed to save’ error. I am able to edit other existing or new pages without any issues.

The website is https://www.ngorganize.com

I have tried the following:

  • Increased memory limit
  • Cleared all cache (browser, CDN, Wordpress)
  • Tried on multiple browsers
  • Saved page as a template and created a new page with the template. Still getting the error

I need to hide or delete the ‘Our Milestones’ section on the page


Hi Anish,

I just checked the console and there is a Javascipt error that might be the root cause of the issue:

Have you tried removing the captcha that you have added in your form somewhere?

If the issue persists, try installing a page duplicator plugin and duplicate that page and try to edit it.

In case you are still not able to edit the page, please provide us with the admin access to your site in a Secure Note:

Hi @jade,

This issue was occurring before I installed the WPForms Captcha. The duplicator plugin is installed and I have tried duplicating the page. The duplicated page has the same issue.


Hey Anish,

I see an error in the console when saving your page.

Failed to load resource: the server responded with a status of 500 (Internal Server Error) cornerstone-endpoint:1

That usually is caused by ModSecurity configuration blocking the cornerstone-endpoint directory. Please contact your web host to whitelist that directory in ModSecurity or other security system.

Please also try saving the page as a template and load the template in a new page.


Hi Christian,

I contacted our web host and they stated that the pro editor added a scrip to the .htaccess file which is probably the cause of the issue and that I will need to identify & modify the script. They also stated that you would be able to distinguish which part of the script is causing the issue.

I have already tried using templates and the issue still exists.


Hey Anish,

Your web host is wrong. Pro does not add or modify the htaccess file and therefore we know nothing of the script the web host is talking about. Since your web host suspected the htaccess, please try resetting it by following this third-party guide: https://www.tipsandtricks-hq.com/how-to-reset-the-htaccess-file-of-your-wordpress-site-using-ftp-8527

I’ve also mentioned about ModSecurity. What did the web host say about that?

Also, did you try saving the page as a template and loading it on a new page as mentioned previously?


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.