Typekit usually won't Refresh - Typekit fonts won't preview in Styles

Hi All,

Typekit fonts usually won’t Refresh (but occasionally will pop in instantly) preview in the Typekit window where I enter the ID, and won’t even preview in X > Fonts.

– Fresh X 6.0.4 install with x-child 1.0.0.
– Typekit ID is good because I’m using it on another site, and I Published it again just to make sure.
– Entered my Typekit ID in X > Fonts > Typekit > Kit Integration.
– Turned on Font Manager in Appearance > Themes > x-child > Customize > Manage Theme Options > Typography.
– Set Body Font = Body Copy and Headings Font = Headings in that same location.

PROBLEM: Going back to X > Fonts, Google fonts will preview within the Styles, but Typekit fonts will not preview. I even created a new Style and set that to a Typekit font, but the Typekit font also wouldn’t preview.

PROBLEM: Quite often, Typekit won’t Refresh and show the font list in X > Fonts > Typekit > Kit Integration. The Available Fonts field only shows Refreshing… until I switch to the Google Fonts tab and then back to the Typekit tab.

How do I get Typekit fonts to link?


Thanks for writing in!

  1. I logged in to your site and I can see that the typekit plugin is not installed. Do you mind installing it again so we can test the issue.

Please review the link below

  1. I tried changing your headline font size and it seems to work.

See Video - https://www.screencast.com/t/fIlzoqpL8a

Please note the second option is for the html tag and will not change the font size.


Hi Paul,

Still no Tk fonts. Didn’t Tk used to work without the plugin? Regardless, unless it takes a really long time for them to propagate, we still have the issue. I didn’t put in any css entries for Tk because I understand that Font Manager is supposed to take care of that.

And I cleared the Style Cache in X > Settings, and have no other cache enabled. WP Super Cache from the install is deactivated and I’ve never turned it on.

I uninstalled WP Super Cache just for safety and cleared the Style Cache again.

Hi There,

Thanks for writing in!

Your domain hasn’t published in typekit.

Please go to your typkit account and verify it. Please check the screenshot for help.


That’s the moving part I forgot to address. It picked up the fonts after adding the new domain at typekit.com and installing the plugin.I took Tk out of the site, though because I decided not to use that font.

Refresh still took a long time, though. Any reason for that that you know?

Thanks again for your help!

Thanks to everyone’s support, I got AddisonOnstage.com up and running and her potential employers are able to see her stage and film portfolio. Many thanks to each of you!

Hi There,

The refresh may be due to slow internet connection or Typekit server response. There is no issue with the theme.
Thanks a lot for your feedback and it means a lot for us.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.