Typekit Font not showing up in Customizer


I am trying to use a typekit font. I entered the kit ID and the kit information is showing the fonts that are in my kit, but when I open the customizer, the typekit fonts are not showing up as an option.

I have read many threads and tutorials, but I can’t get it to work. Please help.


Hey Laura,

Thanks for writing in! The typekit will appear in the font manager. Please go to X > Fonts and create your font template which will use the typekit font. For more details about the font manager, please check this out: https://theme.co/apex/forum/t/font-manager/101/1

Hope this helps.

I have done this, and followed all the steps in the link you sent me, but I am still not seeing the font show up in my customizer and they’re not showing up on my website. How do I fix this?

Hi there,

Please try to use the Theme Options instead of the customizer as the customizer might not have all the options that is offered with X.

You can find it in X > Theme Options.

Also, please make sure that you have created a font setting in the Font Manager and assigned a Typekit font to it so that you will find that font as an option in the Theme Options.

In case you are still not seeing the Typekit fonts, please provide us with your admin details so that we can check your settings

1 Like

This works, thank you.

You’re welcome!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.