Trouble with Cornerstone since update

I'm having a lot of trouble with Cornerstone since the last X theme update. It's not saving the changes I make, and then when I try to reload, often it won't. I've gotten a handful of 500 errors. I've tried deactivating all the other plugins, which didn't seem to help. On one reload, I got the following error:

Any insight would be helpful. Thanks!

Karen

Hey,

This article should useful to you: http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-internal-server-error-in-wordpress/

I've deactivated the plugins, and increased the memory limit. Neither has helped. It's not so much the 500 errors (which are intermittent), but the fact that I can't edit/save content in Cornerstone. When I go to edit a page, sometimes it will just show the cornerstone logo and not display the page at all. When it does display the page, my edits aren't reflected in the preview, and it won't save properly.

Hello Karen,

​To assist you better with this issue, would you mind providing us the url of your site with login credentials so we can take a closer look? This is to ensure that we can provide you with a tailored answer to your situation. Once you have provided us with your URL, we will be happy to assist you with everything.

To do this, you can create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

By the way, are you using CloudFlare or may have installed a caching plugin like WordFence, W3 Total Cache or WP Super Cache? Please keep in mind that after doing every updates, always remember to clear all caches when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Thank you.

I made a secure reply, but for some reason it would only let me do that on my own note. So, just in case it doesn't notify you of the update, I'm bumping it.

Hi Karen,

Plugin page is showing fine when I check:

Checking Cornerstone builder, I got the following error:

(index):14 GET http://dev.vmdsystems.com/wp-includes/css/wp-auth-check.min.css?ver=4.8.3 net::ERR_CONNECTION_TIMED_OUT
jquery.js?ver=1.12.4:4 POST http://dev.vmdsystems.com/cornerstone-endpoint 500 (Internal Server Error)
cs-vendor.js?ver=2.1.4:19500 TypeError: Cannot read property 'indexOf' of undefined

http://dev.vmdsystems.com/cornerstone-endpoint 500 (Internal Server Error). What that error message tells us is that there's something in your system preventing cornerstone-endpoint from loading thereby blocking Cornerstone from saving/functioning correctly. If you could contact your host and they should be able to whitelist the Cornerstone endpoint and get this working.

If you could also ask for error log that would be better because it might give us more information regarding the error. Thank you.

I talked to my host, and they told me that they won't provide support related to themes or plugins. Can you tell me in what way cornerstone endpoint needs to be white listed, so I can be more specific?

Hi there,

The Cornerstone uses some assets and also access to the specific URL which might be blocked by the server. I will send you the URL which is related to your case via secure note.

Before contacting to your hosting service provider, kindly follow up the steps below:

  • Update the theme to version 5.2.4 and Cornerstone to version 2.1.6. This version does have better error logs and may give you proper context.
  • Make sure the Wordpress Debug mode is enabled so that you will see the errors instead of the Error 500.
  • Make sure that you do not have any cache plugins. If you do, purge all caches.
  • Check for a possible 3rd party plugin conflict.

All those stuff above are described in details in the article below which I recommend to follow:

Finally, I suggest that you ask your hosting service provider to give you the latest error log so you can see the actual error to follow up the case.

Thank you.

I updated with the error log in a secure note.

My host (GoDaddy) also said: "The whitelisting cannot be done since we do not block any URLS on our shared hosting."

Thank you for getting back to us with the Error Log. Actually, that revealed the cause. It is the PHP Memory limitation of your hosting service.

The memory limitation can be changed from WordPress and if it will not work for you then you will need to ask your hosting service provider to increase from their side.

So kindly follow the steps mentioned here:

I suggest that you only add yourself to the WordPress installation. If it does not work contact your hosting and ask them to increase. My recommended value for the memory is 512M to be on the safe side. But 256M also should work.

Thank you.

I've increased the memory in wp-config.php and in php.ini. I'm still having intermittent issues, but much less often. It's much more workable now, but I wanted you to know that the issue is still occurring.

Sometimes hosts don't honor memory limit configuration changes made at those levels. You may need to reach out to your host to see if it's truly increased.

Based on those errors, your limit is at 64MB. This is enough to run the front end of WordPress. Everything on the front end is highly optimized. The backend however (content builder) often needs more memory to fulfill certain tasks like loading the builder and rendering elements. You'll want 128MB minimum, especially if you're going to be adding other plugins.

That was it. No more problems despite heavy use in the last day. Thanks for sticking with it.

Ok great! Glad to hear that fixed it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.