Theme option not working on server domain

Hi there,
it looks like theme options is not working on my server domain.

Hi @jlampreia,

The home and site URLs should be the same for the Page Builder to be able to show the preview panel.

This is usually happening if you use the Staging tool of the hosting service provider. If you set a domain to the staging website you should have no problem.

You can go to Settings > General to see the home and sire URL>

Thank you.

Thank you Christopher,
so i go to Settings > General and save a Custom Path url?

Hi @jlampreia,

Is http://xxxxxxxx/~flxmdxcr/ the base URL of the staging site? If so, that should be the Site and Home URL that will be set in the settings.

Please make sure to keep a full backup of your site before changing any setting.

If the issue persists, please provide us with the admin access to your site in a Secure Note:

Hello @jlampreia,

It looks like your ModSecurity is enabled. Please temporarily disable ModSecurity and test the page again.
If this time around it works, then you will have to whitelist the url in your server.

Check the secure note.

Hi RueNel,
thanks for the reply. i have disabled ModSecurity, Theme Options still not working.
I will try to whitelist the url.

Sure, let us know how it goes. :slight_smile:

Hi Prasant,
I have whitelist my ip and still not working, i can’t figure it out. :disappointed_relieved:

Hey @jlampreia,

Would you mind providing us the FTP login credentials so we can take a closer look? This is to ensure that we can provide you with a tailored answer to your situation. Once you have provided us with your URL, we will be happy to assist you with everything.

To do this, you can make a post with the following info:

  • FTP Hostname
  • FTP Username
  • FTP Password

Thank you.

OK thank you for your help.

Hello @jlampreia,

The FTP details do not work for us. The password is incorrect.

Please double check it.

RueNel, sorry for that.

Hello @jlampreia,

I already have checked your files and I am still seeing the fatal error when you load the Theme options. Can you please disable Mod Security so we can do another test?

Please also upgrade your PHP version to at least 7.3

Kindly let us know how it goes.

Hello RueNel,
thank you for the post update.

I´ve disabled ModSecurity and also upgraded PHP to 7.3 version. I tested on PHP 7.3 the website gives a blank page, so i have downgrade PHP to 7.2 version.

With ModSecurity disabled and PHP 7.2, Theme Options don´t start.

Hey @jlampreia,

When opening Theme Options, there’s a Fatal Error message displayed in the console.

The exact error is usually recorded in an error logging file like the WP debug.log. Thankfully, you have set it up.

The exact error according to the debug.log is this:

[26-Aug-2019 11:07:41 UTC] PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/flamdecr/public_html/wp-includes/wp-db.php:1643

The problem is with your database. Please try upgrading and downgrading your MySQL version. Your host will be able to help you with that as this issue is server related and not with our theme.


Hi Christian, thank you for the post update,
i did forward the error to my host provider, they told me to active the option nd_mysqli and disable mysqli, witch i did and the error still persists.

Hi @jlampreia,

I understand that you already tried disabling the ModSecurity, but this 500 Internal server error has something to do on your server.

This issue is only happening to whichever page is set as front page (homepage), I was able to confirm this when I change the front page to the test page that I created, that test page becomes uneditable in Cornerstone and the Início page can be now edited. The issue is happening on Theme Options because theme options loads the homepage

Please contact your hosting support and ask to deactivate the ModSecurity, then check your homepage in Cornerstone to see if that resolves the issue. If it does, since deactivating ModSecurity is not recommended, request to enable it back and unblock/whitelist only the removed as requested

Another thing, please update your Wordpress to latest version 5.2.2 to avoid any incompatibility issues.

Hope it helps,

Hello Friech,
can you please hide my IP?

I going to contact my Hosting and explain the issue,
Thank you for the post update.

Hi @jlampreia,

I removed the URL of your website as requested.

Thank you.

1 Like

The hosting disabled ModSecurity,
i tested theme options and no sucess.

I think it´s better to buy a domain and get the website done.